Electical problems? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-02-2009, 10:19 AM
Powerstroke.org Fanatic
 

Join Date: Jun 2008
Posts: 107
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Electical problems?

I have had my truck for about 6 months now. I bought it used, and it had a clear oasis report. Things look a little odd where my fuses are, and lately I have been getting a trailer fault alert for about 3 minutes randomly. It will beep and say trailer fault over, and over again. Yesterday, I was driving and my horn just started to go insane. It was honking for a good 5 minutes before it stopped. What is going on?! 2005 F-250, SCT tuned, exhaust, intake
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-02-2009, 10:41 AM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Pasadena, TX
Posts: 6,512
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Stop pushing the middle of the steering wheel.....

I don't know what is going on with your truck. Do you have pics of the "weirdness" going on at the fuse block? I bet somebody has wired some stuff in there and it's shorting out.......
Reply With Quote Quick reply to this message
  #3  
Old 02-02-2009, 10:47 AM
Powerstroke.org Fanatic
 

Join Date: Jun 2008
Posts: 107
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i can get a picture later today. there is a fuse that is hanging down (not in fuse box) with wires going to and from it wrapped in electrical tape. my truck has had a rough go this week... broken into on tuesday and keyed on thursday
Reply With Quote Quick reply to this message
  #4  
Old 02-02-2009, 10:51 AM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Pasadena, TX
Posts: 6,512
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Dang, that sucks. Sorry to hear that. Did they steal anything? If they tore up any wiring that could be the cause as well....
Reply With Quote Quick reply to this message
  #5  
Old 02-02-2009, 03:21 PM
Powerstroke.org Fanatic
 

Join Date: Jun 2008
Posts: 107
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
nothing was stolen, and i don't think they messed with my wires.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:10 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors