weird electrical problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-31-2008, 11:01 PM
Compression Ignition Addict
 

Join Date: May 2008
Location: Wilmington, MA
Posts: 239
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
weird electrical problem

hey guys, so today i pulled my interior light down and put my beacon light wires thru the hole so i could turn the beacon on when i pushed the round knob all the way up for the interior light. so all worked well as i plowed, when i was done, i pulled the wires off the bulb and let them dangle (bad idea) i noticed that the beacon was flashing later that night when i was driving so i pulled the plastic cover off the interior light and went to move the wires and it sparked. right after that i lost power to my radio, my power windows and the two small interior lights on the sides but i still have the middle interior light working. any suggestions? i went thru the owners manual and cant figure out what fuse blew.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-31-2008, 11:15 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Location: reading,pennsylvania
Posts: 357
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via MSN to pinkfloyd
why would you want your interior light on while you're plowing? why don't you hook your beacon up to a switch?
Reply With Quote Quick reply to this message
  #3  
Old 01-01-2009, 07:03 AM
Compression Ignition Addict
 

Join Date: May 2008
Location: Wilmington, MA
Posts: 239
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
the interior light was not on when i plowed, i pulled the bulb and wrapped the wires to the beacon around each terminal from the bulb.
Reply With Quote Quick reply to this message
  #4  
Old 01-01-2009, 10:11 AM
Compression Ignition Addict
 

Join Date: May 2008
Location: Wilmington, MA
Posts: 239
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
instrument cluster fuse was blown.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:22 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors