Integrated Brake Controller not working - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 10-02-2008, 04:34 PM Thread Starter
Premium Member
 
Join Date: Jul 2008
Location: Newberry, FL
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Integrated Brake Controller not working

Hi gang,

My 05 F-250 is experiencing some trouble with the brake controller. The LCD panel in the cab is functioning, and I'm able to adjust the gain. When I hooked my camper up for the first time, I noticed that the trailer brakes did not seem to be engaging. I turned the gain up to 10 and then started the trailer just barely rolling and engaged the manual lever. It didn't even slow it down. My old F-150 with a Tekonosha P3 would deploy the airbags if I used the manual control turned up all the way. I did hook the camper up to my dad's truck and using his Tekonosha controller the brakes lock up immediately with the manual control so I know the trailer brakes are working. Is there something I'm missing with this controller? Will it not work at low speeds? If something is wrong, should I take it to my dealer, or to the RV shop in town?

Thanks for any help you guys can give me. I wasn't sure if I should post this here or the Electronics forum so I'm sorry if it is in the wrong spot.

2005 F250 PSD CC Lariat Fx4
kilobravo3 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 10-02-2008, 04:39 PM
Compression Ignition Addict
 
Join Date: May 2007
Location: America
Posts: 6,782
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
If it comes down to it take to the dealer to get fixed.
2005F250 is offline  
post #3 of 4 Old 10-03-2008, 06:17 AM Thread Starter
Premium Member
 
Join Date: Jul 2008
Location: Newberry, FL
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just wanted to post an update to my question in case anyone else has this problem. I did some more research and apparently trucks with a build date before 3/23/05 behave exactly the same way as my truck does. Essentially there is little to no braking supplied to the trailer below 15 MPH. I'm going to haul the camper down the road over the weekend to make sure it works above 15, but it seems like that is my problem. Since I don't pull a 5er and don't need to lock the wheels at slow speeds, I'm not going to worry about it to much.

2005 F250 PSD CC Lariat Fx4
kilobravo3 is offline  
post #4 of 4 Old 10-04-2008, 03:03 PM Thread Starter
Premium Member
 
Join Date: Jul 2008
Location: Newberry, FL
Posts: 51
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just wanted to post the final resolution to this just in case anyone else runs across this problem. My brake controller does not work at very slow speeds (less than 10 or 15), but once the truck is above that the controller works very nicely. So, if you have a brake controller that was manufactured before March 2005, then you will likely have similar performance.

2005 F250 PSD CC Lariat Fx4
kilobravo3 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome