radiator smell when pulling load 04 - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 2 Old 09-23-2008, 07:08 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Sep 2008
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
radiator smell when pulling load 04

Truck is a 04 6.0l with 88k. I can pull a 4000lb boat no problem, when i hook onto my 10,000lb camper it never overheats or looses any fluid but in the cab i smell radiator fluid. The dealer cleaned EGR, still happening, so they replaced EGR, HEAD GASKETS, AND BURB JUG. Still smell this radiator smell. In the begining the dealer witnessed smell with my camper behind truck, now dealer is saying he cant replicate smell with or without load. Any advice would be grately appreciated
Tyjack is offline  
post #2 of 2 Old 09-23-2008, 07:13 PM
Compression Ignition Addict
 
Join Date: May 2007
Location: America
Posts: 6,782
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Heater core or maybe the radiator cap is bad.
2005F250 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome