2003 6L turbo - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-30-2008, 12:18 PM
Powerstroke.org Rookie
 

Join Date: Aug 2008
Location: 100 miles west of williams lake
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2003 6L turbo

How do i tell if my turbo is still working or not? My truck does not smoke but it is low on power and I don't think there is any turbo whine, after about 2000 rpm there is a loud whooshing sound. It is low on power though, but not horrible it will still cruise at 70 mph no prob.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-30-2008, 12:24 PM
Compression Ignition Addict
 

Join Date: Nov 2006
Location: forest lake, minnesota
Posts: 2,290
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
get a code reader and scan it and post up the codes
Reply With Quote Quick reply to this message
  #3  
Old 08-30-2008, 12:50 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Posts: 1,314
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'd also look under the hood at the CAC boots and see if one blew off or split. That would explain low boost/whooshing noises.
Reply With Quote Quick reply to this message
  #4  
Old 08-30-2008, 12:54 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Williamsport, MD
Posts: 2,229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by tech10002 View Post
I'd also look under the hood at the CAC boots and see if one blew off or split. That would explain low boost/whooshing noises.
+1. This would be my first move. Make sure that everything from the intake back is connected correctly. Also check all the boots on the IC. I blew a boot off of mine and had the same problems you are describing.
Reply With Quote Quick reply to this message
  #5  
Old 08-30-2008, 01:43 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Location: michigan
Posts: 4,241
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
+2 on my old 03 6.0 the hole was kinda hard to find but it was on the underside of the boot.
Reply With Quote Quick reply to this message
  #6  
Old 08-30-2008, 01:46 PM
one day at a time

 

Join Date: Oct 2006
Location: Tipton, Iowa
Posts: 9,451
Thanks: 4
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
You could just send me your turbo and pedistal and I'll swap you mine... Then you'd know for sure....
Reply With Quote Quick reply to this message
  #7  
Old 08-30-2008, 01:53 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Williamsport, MD
Posts: 2,229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by shu873 View Post
You could just send me your turbo and pedistal and I'll swap you mine... Then you'd know for sure....
There are two of them on ebay right now.
eBay Motors: turbocharger ford powerstroke 6.0 (item 140261450276 end time Sep-01-08 19:23:26 PDT)

eBay Motors: FORD POWERSTROKE 2003 GARRET TURBO DIESEL 6.0 (item 270269890424 end time Sep-01-08 19:14:28 PDT)
Reply With Quote Quick reply to this message
  #8  
Old 08-30-2008, 02:27 PM
Powerstroke.org Rookie
 

Join Date: Aug 2008
Location: 100 miles west of williams lake
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Found a hole on the under side of the IC line, ford has one in stock, will let you guys know if it fixes the problem, thanks everyone!!
Reply With Quote Quick reply to this message
  #9  
Old 08-30-2008, 02:30 PM
Compression Ignition Addict
 

Join Date: Jul 2007
Location: michigan
Posts: 4,241
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by woody2850 View Post
Found a hole on the under side of the IC line, ford has one in stock, will let you guys know if it fixes the problem, thanks everyone!!
im sure thats your problem. like i said, mine did the same thing on the underside. those boots are like $60 tho i think
Reply With Quote Quick reply to this message
  #10  
Old 08-30-2008, 03:07 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Williamsport, MD
Posts: 2,229
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by woody2850 View Post
Found a hole on the under side of the IC line, ford has one in stock, will let you guys know if it fixes the problem, thanks everyone!!
Glad you found the problem! Let us know how things shake out.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:02 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors