03 EGR CEL - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-24-2008, 06:53 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Posts: 467
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 EGR CEL

So I have an 03 6.0, took my truck out for a normal drive and let it cool down, then turned it off.

Read on the ORG and went out and unplugged my EGR figuring it would give no CEL since its an 03.

Drove to the local winery to stock up and about 20 miles into it CEL goes on (doh).

So my question is did I do something wrong??

I have an SCT from DJ but I think they left the EGR on since I didn't tell them to take it off. And I dont want to disturb vivian with current problems she is having with her grandfather.

Also I just need to add an 1 1/2 freeze plug, to block it off as well right, called some places but none have it, any ideas?? Thanks!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-24-2008, 06:59 PM
Compression Ignition Addict
 

Join Date: Nov 2007
Location: Las Vegas, Nevada
Posts: 1,039
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Im not 100% but I believe all the custom tunes from djs come with egr disable already in the programming. I know Innovatives do for certain.
Reply With Quote Quick reply to this message
  #3  
Old 02-24-2008, 07:04 PM
Compression Ignition Addict
 

Join Date: Jan 2008
Location: Crownsville md
Posts: 486
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i got an 04 egr been unplugged for 2 weeks no cel
Reply With Quote Quick reply to this message
  #4  
Old 02-24-2008, 07:46 PM
Member
 

Join Date: Aug 2007
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I unplugged mine yesterday. Drove about 100 miles today no CEL. Mileage seems to be better. Guess running hot air in the engine aint good for it.
Reply With Quote Quick reply to this message
  #5  
Old 02-24-2008, 07:56 PM
Premium Member
 

Join Date: Sep 2007
Location: Hubbard, Texas
Posts: 1,112
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
My 03 has been unpluged for a moth or more now and there is no CEL. My mileage did go up about a mile. My EGR system is completely bypassed now and there is no CEL. Maybe something else is causing it?
Reply With Quote Quick reply to this message
  #6  
Old 02-24-2008, 08:18 PM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Wasco, ca
Posts: 528
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
on my 03 i unplugged it and turned it on and no cel. but once i turned it off and then back on the cel came up. I know its because of the egr. but i wonder why it hasnt shown up for other people.
Reply With Quote Quick reply to this message
  #7  
Old 02-25-2008, 09:38 AM
Powerstroke.org Fanatic
 

Join Date: May 2007
Posts: 119
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have plugged my flow on my 03 with elites little block off plate, And i have run plugged and unplugged on the EGR connector and not really any difference and no CEL. I do like to see the IAT sensor stay clean since I plugged the EGR Flow. I picked up 1-2 MPG when I plugged my EGR flow off and no more surging under acceleration either.
Reply With Quote Quick reply to this message
  #8  
Old 02-25-2008, 09:58 AM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: Rhinelander,WI
Posts: 273
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sorry guys I feel silly but what do you mean by CEL?
and if I unplug my egr it will run normal and I might gain a couple of MPG's?

thanks in advance for the help
Reply With Quote Quick reply to this message
  #9  
Old 02-25-2008, 10:03 AM
Compression Ignition Addict
 

Join Date: Sep 2007
Location: Wasco, ca
Posts: 528
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
CEL= Check Engine Light . kind of looks like that.
Reply With Quote Quick reply to this message
  #10  
Old 02-25-2008, 10:08 AM
Compression Ignition Addict
 

Join Date: Dec 2006
Location: Rhinelander,WI
Posts: 273
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
OH That Light....
thanks I should have figured that out. monday so I guess I'm not up to speed yet
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:07 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors