Question for the techs - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 11-16-2007, 01:42 PM Thread Starter
Compression Ignition Addict
Join Date: Jul 2007
Posts: 1,314
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Question for the techs

My truck has been in and out of service for weeks for some issues that are not repaired yet. I think the service manager is handing me a line, but I wanted to know what the techs here thought.

My main issues are the moaning noise from the exhaust and poor fuel economy. The moaning issue is addressed in a TSB, 05-19-12, but the dealer is unwilling to perform the TSB procedure, just stating that it won't do any good. My other main issue is poor fuel economy. I'm getting no better than 12-13, and it used to get in the high teens on the road.

I've also noticed I get turbo fart constantly now when it's cold, even from very low boost levels, and I don't ever see more than 28 PSI of boost. The truck definitely does not have as much power as it used to. All of this is running with the truck completely stock.

The dealer has not run any diagnostics and refuses to even check the EGR without a fault code present. They won't even do a reflash. They say since the fuel economy is not rated on the diesels, they can't look into fuel economy complaints either. So far the only thing they did is take apart the turbo and clean it. That did absolutely no good.

Is this really standard procedure with Ford?

2006 F-250 Powerstroke Crew Cab Lariat Long Bed 4x4 FX4

SCT Xcal2 with Xtreme tunes by Innovative

Banks Monster Exhaust/Quadzilla Commander

ARP Head Studs and Elite Sneaky Pipe (Thanks Scuffy)
tech10002 is offline  
Sponsored Links
post #2 of 2 Old 11-16-2007, 08:58 PM Rookie
Join Date: Nov 2007
Location: Perryville ,Ar
Posts: 25
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like you have a sorry dealer. I am not a tech but that don't sound right. We just had a 04 6.0 at the dealer they went above and beyond to make it right. You can read part of the story in this forum under EGR sensor
hargrove is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome