Piaa light problems - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 12-09-2012, 03:57 PM Thread Starter
Compression Ignition Addict
Njstroker91's Avatar
Join Date: Aug 2012
Posts: 632
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Piaa light problems

I'm currently having a problem with my fog lights in my road armor bumper they are piaa 510's and it seems like one day one will work then they both will work then only the opposite side will work. I have replaced the harness thinking it was shorted but still doing the same thing. I've checked and double checked the harness and everything is hooked up correctly. Any one got any experiences like this or any tips would be much appreciated thanks.

Sent from my iPhone using AutoGuide.com App

2006 f350 eclb 6 speed, powermax, billet compressor wheel, valair dual disk, 4in to 6in cat stack, afe magnum force stage 2, airdog 150, xdp sump, zoodad mod, sinister coolant filter, gauges egt oil temp and fuel pressure, cfm carbon fiber and metal cold side tub, blue spring, bpd ficm, moto metal 959 18x9 wrapped with cooper at3, custom shift knob from lilpooh, Polk audio all the way around, dashboss for monitoring
Njstroker91 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome