P0404 Code... Please Help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-06-2012, 08:14 PM
Member
 

Join Date: Jul 2012
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
P0404 Code... Please Help

Hey everyone.

I have a 06 F350, blue spring upgrade, straight piped exhaust, airaid air filter. No tuner or other mods. Basically stock. I was driving down the road and I noticed the engine light came on today. It did not miss a beat. Runs the same from what I can tell. Only thing I really did notice was no white smoke (its cold here) no smoke at all from what I can see driving at night. I scanned my truck just now and gave me a P0404 code which from some quick forum research points to a egr valve being clogged or needs replacement. I just replaced it about 3 or 4 months ago. Could it really be that? Any thoughts?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-07-2012, 05:51 AM
Member
 

Join Date: Jul 2012
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
update: I changed my egr vavle. it was not clogged up. I did not drive the truck yet but the engine light is still on. Do I have to drive the truck or does the light need to be reset?
Reply With Quote Quick reply to this message
  #3  
Old 12-07-2012, 11:53 AM
YEA!! Tip Assist!!

 

Join Date: Jul 2012
Location: bluff dale
Posts: 1,076
Thanks: 2
Thanked 10 Times in 9 Posts
Feedback Score: 0 reviews
Reset it. See if it throws it again
Reply With Quote Quick reply to this message
  #4  
Old 12-07-2012, 02:11 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,199
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
What are you pulling codes with? That code doesn't normally turn the cel on, I don't think. The cheap *** code readers are not always going to pull all the codes. You may have another code it's not pulling.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:06 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors