Idle Issue - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-05-2012, 01:33 PM
Powerstroke.org Rookie
 

Join Date: Dec 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Idle Issue

Since this is my very first post, I hope I am putting in in the correct section! Please don't be too judgemental.

A few months ago, the idle was intermittingly rough and would do a slight surge at a stop light. When that would happen the RPMs would go up and then back down. We replaced the ICP and it ran great with no issues for a month.
Now upon cold starts, the truck idles rough. After a longer drive, it does smooth out. So far there are no performance issues, but the rough idle went from slight to far worse and it taking longer and longer to smooth out.
There is no black or white smoke, no oils leaks, fuel leaks, no codes that come up, and the check engine light has not come on once.

Any ideas of what is going on?

BTW….the FICM was recently repaired by FICMrepair.com so I know that cannot be an issue either.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-05-2012, 01:37 PM
Compression Ignition Addict
 

Join Date: Jul 2012
Location: bel air, maryland
Posts: 1,965
Thanks: 4
Thanked 30 Times in 23 Posts
Feedback Score: 1 reviews
You should check the ficm anyways, just for a piece of mine.. I would get your injectors tested. I had a rough idle all the way up to around 1200 rpm when cold and i lost an injector. Did you replace the pigtail when you replaced the icp?
Reply With Quote Quick reply to this message
  #3  
Old 12-05-2012, 02:05 PM
Powerstroke.org Rookie
 

Join Date: Dec 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I agree, we should check the FICM just in case. I don't think it is the issue, but you're right, I would rather have piece of mind.
We did not change the pigtail when we changed the ICP. Could that cause this idle issue?
Reply With Quote Quick reply to this message
  #4  
Old 12-05-2012, 02:21 PM
Compression Ignition Addict
 

Join Date: Jul 2012
Location: bel air, maryland
Posts: 1,965
Thanks: 4
Thanked 30 Times in 23 Posts
Feedback Score: 1 reviews
Yes the pigtail is the big reason for the icp going bad.. Change the pigtail for piece of mind as well
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:01 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors