slow crank and no start - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 11-30-2012, 06:44 PM Thread Starter
Join Date: Nov 2012
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
slow crank and no start

2006 F350 SRW. 4X4.
Ran rough and threw P0270/P0299/P1102. which prompted me to get a new FICM for the injector low circuit, rebuild the turbo (it was gunked up something fierce) and get a new MAF sensor.
As stated it turned over and ran rough until it warmed up and then smoothed out. Before all the parts were replaced/rebuilt it would turn over one day.
it cranks really slow about 1/2 the speed of normal. It doesn't even pretend to want to start, no sputter no smoke nothing. initially thought bad batteries (duralast bought in July 2012) so I had them checked and charged but same thing, a really slow crank.
Everything is back together and guess what even after charging the batteries a second time still a really slow crank, no smoke, no sputter nothing. I'm lost.
Are the batteries no good after so many tries to turn it over? Possible bad starter?
F350project is offline  
Sponsored Links

cranks but no start, no start, slow cranking

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome