Don't think anything is wrong, looking for 2nd opinion - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-29-2012, 05:08 PM
Chapter Director
 

Join Date: Oct 2007
Location: Gloucester, va
Posts: 1,206
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Don't think anything is wrong, looking for 2nd opinion

hey guys whats up,

so i had a question or 2 about somethings with my truck, i don't want to say something is wrong but i'd like to see what you guys think.

Well i've always felt that the power seems inconsistant everytime i drive my truck, could just be me but thats why im asking for help. i do have an edge cts and i've noticed that my boost doesn't always peak the same. I can roll into hit 25-27psi one pull. I can slow back down and do the same thing and maybe only hit 23-24psi, i have seen 29psi like 2 times but thats it. No check engine lights but i do frequently get a P006a code for mass correlation incorrect (something like that?)
Reason i am finally asking is cause i was on my way home from work today and had a lifted chevy 2500hd gas motor trying to pick a fight and i couldn't really pull on him very well and felt very slow like i wasn't really accelerating, i was actually kinda embarassed.
Thats another thing the power i do have is awesome down low but at highway speed doesn't really feel like i have much get up and go.

Looking for any input, i can get more info or engine data to help in determining anything just ask.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-30-2012, 05:52 AM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
I have a stock 04', no tune, I was only seeing 19lb of boost and it was kindof a dog as you describe. I pulled my turbo last weekend and cleaned it up. It wasn't that bad, I didn't think, but it spools up much quicker and smoother on accel, i'm consistently seeing 23lb, and a little higher sometimes, 26lb one time no load. I assume you will see different numbers with a tune, but it woke my truck up. No codes either. What do you see cruising on flat ground.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #3  
Old 11-30-2012, 06:04 AM
Compression Ignition Addict
 

Join Date: Feb 2008
Posts: 8,294
Thanks: 69
Thanked 199 Times in 189 Posts
Feedback Score: 0 reviews
with a durastroke and custom tunes u won't have many folks who can relate

but I do know sometimes going down the 2 lane merging on ramp if I have to get on it I have had the same issue ,, sometimes it goes and sometimes it seems slow

I was thinking it was a tourque converter lock issue .. I just went with a new tune to try and eliminate the issue
Reply With Quote Quick reply to this message
  #4  
Old 11-30-2012, 04:42 PM
Chapter Director
 

Join Date: Oct 2007
Location: Gloucester, va
Posts: 1,206
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yea turbo only has a few thousand miles so doubt its dirty. Cruising on flat ground I see about 5-7. I didnt think these trans or converters had much of an issue. I do know I need to flush transmission. Hope someone has some kind of idea
Reply With Quote Quick reply to this message
  #5  
Old 12-03-2012, 03:46 PM
Chapter Director
 

Join Date: Oct 2007
Location: Gloucester, va
Posts: 1,206
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
anyone else have any other ideas
Reply With Quote Quick reply to this message
  #6  
Old 12-03-2012, 04:33 PM
Member
 

Join Date: Dec 2012
Location: North Augusta
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Subscribed
Reply With Quote Quick reply to this message
  #7  
Old 12-05-2012, 04:24 PM
Chapter Director
 

Join Date: Oct 2007
Location: Gloucester, va
Posts: 1,206
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
please help
Reply With Quote Quick reply to this message
  #8  
Old 12-05-2012, 04:28 PM
Premium Member



 

Join Date: Dec 2011
Location: Spokane, WA
Posts: 18,104
Thanks: 74
Thanked 121 Times in 112 Posts
Feedback Score: 5 reviews
When I was on stock injectors it ran great at low speeds but highway racing it was kinda slow... It is an 8000# truck!

now with injectors, it runs like a beast.

I did notice your boost is fine per the CTS (it shows a couple psi low all the time compared to regular gauge)

maybe leaky intercooler pipe or exhaust pipes...
Reply With Quote Quick reply to this message
  #9  
Old 12-05-2012, 05:10 PM
Chapter Director
 

Join Date: Oct 2007
Location: Gloucester, va
Posts: 1,206
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
could a leaky pipe cause inconsistent boost #'s not just low. cause sometimes i get higher numbers like 28-29psi, other times i have only gotten like 24psi.
Reply With Quote Quick reply to this message
  #10  
Old 12-05-2012, 05:17 PM
Compression Ignition Addict
 

Join Date: Aug 2009
Location: southwestern kansas
Posts: 370
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
subscribed having the same kind of problems even running erics extreme race. low boost and falls flat on its face some days then others it seems like it could take over the world.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:02 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors