just changed bad injector now wont start. low icp - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-16-2012, 05:33 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2012
Location: great falls, MT
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
just changed bad injector now wont start. low icp

Please help I changed #8 injector because it was bad and now my truck wont start had to have been something I overlooked when I put it back together. I primed everything back up by turning key off and on a few times listened to the pumps run before trying to crank. I am watching my cts and I am only getting 65 psi in the icp pressure. What else do I need to monitor ans what could cause this please help. Thanks guys
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-16-2012, 06:33 PM
Premium Member
 

Join Date: May 2012
Location: Anchorage
Posts: 1,355
Thanks: 20
Thanked 40 Times in 34 Posts
Feedback Score: 1 reviews
You will have a lot of air in the rails from changing the injector, it will take quite a few long cranks before it will fire.
Reply With Quote Quick reply to this message
  #3  
Old 11-16-2012, 06:47 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2012
Location: great falls, MT
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks I am in the process of refilling the hi pres oil system under the valve cover
Reply With Quote Quick reply to this message
  #4  
Old 11-16-2012, 06:55 PM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Tuscaloosa, Al
Posts: 1,398
Thanks: 2
Thanked 17 Times in 14 Posts
Feedback Score: 0 reviews
Did you make sure the o-rings on the stand pipe and dummy plug was good and didn't have any tears in them? It sounds like you are leaking thru on one of the o-rings and that will keep the truck from building enough oil pressure to start. Just my two cents.
Reply With Quote Quick reply to this message
  #5  
Old 11-16-2012, 07:46 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2012
Location: great falls, MT
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Generally how long and how many times should I be trying to turn it over? Just put it all back together and tried turning it over for probably about a minute pres got up to 92 and just stayed around there when I stopped presure dropped to 52. Hopeing I dont have to pull it apart again to double xheck dummy plug everything looked good when I took it apart the first time.
Reply With Quote Quick reply to this message
  #6  
Old 11-16-2012, 07:56 PM
Premium Member
 

Join Date: May 2012
Location: Anchorage
Posts: 1,355
Thanks: 20
Thanked 40 Times in 34 Posts
Feedback Score: 1 reviews
It took me about 5 or 6 long cranks about 20 to 30 seconds each for my hpop to build pressure and the motor to fire. Once it does fire don't shut it off the air will allow it to bleed pressure off and you will have hard starts again. Don't wait too long in between cranks, but don't burn up the starter either.

Did you have any problem with the stand pipe when you were putting back together?
Reply With Quote Quick reply to this message
  #7  
Old 11-16-2012, 08:09 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2012
Location: great falls, MT
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No problems everything went back together great.
Reply With Quote Quick reply to this message
  #8  
Old 11-16-2012, 08:19 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2012
Location: great falls, MT
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ok well I am done for tonight batteries died going to get a charger tomorrow and try again if nothing after about 6 cranks ill pull it apart again ans double check orings
Reply With Quote Quick reply to this message
  #9  
Old 11-17-2012, 12:03 AM
Member
 

Join Date: Jan 2011
Location: Binghamton, NY
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mine took a while as well i had to have my brothers truck hooked to mine with jumper cables at one point; on a side note one of my stand pipes flopped down when i went to re-install the oil rail and i only noticed because it hit my fingers when i was moving everything. just a heads up
Reply With Quote Quick reply to this message
  #10  
Old 11-18-2012, 08:50 AM
Powerstroke.org Fanatic
 

Join Date: Feb 2012
Location: great falls, MT
Posts: 135
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok i have double checked everything tore it to the injectors 3 times checking o rings. cleaning everything, and making sure everything was good. everything is good but still will not start. i have gone through about 6cycles of 30 seconds of starting with 30 seconds of starter cool down ect ect. i am watching my dash and cts my oil pressure on the dash comes up instantaneously and the edge slowly gets to around 125psi on icp pres and will not go higher than that. at one point i did spray a little starter fluid just to see and it tried to crank so that would tell me that everything is good except the oil pressure. what do i do next??? any help will be greatly appreciated.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:38 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors