fuel pump issue... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-02-2012, 05:02 AM
Compression Ignition Addict
 

Join Date: Sep 2010
Location: Delaware
Posts: 797
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
fuel pump issue...

While making a turn today my truck felt just like it did when the egr valve stuck. No poweer off idle like it had no fuel. So I figure the fuel pump is dying, will check pressure to confirm shortly. Question is that tousely lists two fuel pumps for the truck, one is 520 bucks under the injector pump title and the other is 275 under the title of fuel pump, so which is the one that fails?

Only lasted for a second tops but damn near stalled out in the middle of a busy highway....damn thing.

Jason
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-02-2012, 06:29 AM
War is the answer!


 

Join Date: Feb 2011
Location: Daytona Beach, Florida
Posts: 5,055
Thanks: 101
Thanked 64 Times in 19 Posts
Feedback Score: 2 reviews
What does it do under wot? Mine was the fuel water seperator. But mine would take off great from a red light but after that it was like a dog. Have you tested your pump to see if its bad or are you just guessing? Any CEL s?

Sent from my SPH-L710 using AutoGuide.Com Free App
Reply With Quote Quick reply to this message
  #3  
Old 11-02-2012, 08:18 AM
Compression Ignition Addict
 

Join Date: Sep 2010
Location: Delaware
Posts: 797
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just a guess since it happened on my way to work, will pull the codes from my cts to see when I get home. Under wot it runs fine, plenty of power and pulls my work trailer fine.

Jason
Reply With Quote Quick reply to this message
  #4  
Old 11-02-2012, 08:41 AM
Compression Ignition Addict
 

Join Date: Sep 2010
Location: Delaware
Posts: 797
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well my CTS has decided to be a pos and I can't access anything on it, its stuck at my current display...

Jason
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:07 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors