Dead batteries again!!!!!? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-17-2012, 08:20 PM
Powerstroke.org Rookie
 

Join Date: Sep 2012
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Dead batteries again!!!!!?

Ok so I've had battery problems for weeks now I was having problems with the batteries dying I my truck set overnight well come to find out the voltage regulator on the alternator was bad and somehow I made it back from Tennessee after this happened by jumpin it off and hitting the road.. Got home put a new alternator and batteries in... The truck ran great for about 2 days then started running-idling rough until warm so I knew I messed the ficm up so I took it off did the fix myself at work yesterday but I didn't unhook the batteries before I took it off and I put the fixed module back on 2 days later and the batteries were dead as crap? Could me not unhooking the batteries caused this? I jumped it off and it ran great.... Funny thing though my alternator was warm to the touch after sitting all day? Could the switch be bad? Idk I've tried everything
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-18-2012, 03:33 AM
Compression Ignition Addict
 

Join Date: Apr 2007
Posts: 2,547
Thanks: 8
Thanked 14 Times in 11 Posts
Feedback Score: 0 reviews
Lots of folks have gotten bad alternators right out of the box from the parts stores. Where did you get the alternator?
Reply With Quote Quick reply to this message
  #3  
Old 10-18-2012, 03:45 AM
Powerstroke.org Rookie
 

Join Date: Sep 2012
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
O'reilieys.... But I've had it rebuilt since I bought it 3 weeks ago and the voltage regulator was sticking and some brushes were bad so by no means was it a "new" one like they said
Reply With Quote Quick reply to this message
  #4  
Old 10-18-2012, 08:38 AM
War is the answer!


 

Join Date: Feb 2011
Location: Daytona Beach, Florida
Posts: 5,055
Thanks: 101
Thanked 64 Times in 19 Posts
Feedback Score: 2 reviews
I went through 3 before I got a good one.

Sent from my SPH-L710 using AutoGuide.Com Free App
Reply With Quote Quick reply to this message
  #5  
Old 10-18-2012, 11:37 AM
Powerstroke.org Fanatic
 

Join Date: Jul 2011
Posts: 131
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
article in current trailer life recommends that a ground wire be run from alternator to engine ground. said a lack of one cause a lot of problems. They were rebuilding alts for the turtle expedition truck.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:24 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors