HPOP system questions - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-15-2012, 04:43 AM
...swamp trash...
 

Join Date: Apr 2012
Location: Lake Worth
Posts: 2,268
Thanks: 77
Thanked 110 Times in 85 Posts
Feedback Score: 1 reviews
HPOP system questions

Hi guys,

Gonna bug ya with a few simple questions. Just trying to educate myself a little more. Well did my dummy plugs and standpipes this weekend added rev x and changed from Rotella dino oil to T6 and did a few odds and ends. I previously had extended starts and bad stiction. Dang... what a difference that made! Starts up no problem and takes off with great drivability. Don't know why I didn't do it earlier, drove the truck for 2 years without doing really much to it and running dino oil. Thought it was just a simple machine and was uneducated on my 6.0. Until I started hanging around here. So.... shame on me, this thing really fascinates me now. Anyway enough rambling, on my edge cs at idle icp voltage usually hangs out around .8 volts, used to be 1.2 volts is that because the ipr is staying open more because I found my hpop leak ( bad o ring on d plugs). Also, it fires right up, but the low pressure oil gauge doesn't move until running, heard it should move as you crank. Just curious if I should worry about the idiot gauge on the dash, I mean, if it fires right up, what more can you ask for? Not really worried the figured I'd ask.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-15-2012, 04:58 AM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
First off, my icp is .8 - .9 at idle, I think your right on your thinking. And I found this is why my dash guage doesn't jump up quickly, check it out.......Questions? Oil filter housing is dry. With pics.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #3  
Old 10-15-2012, 04:59 AM
Compression Ignition Addict
 

Join Date: Jun 2012
Location: O'Fallon,Mo
Posts: 845
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
most dummy lights wont move till they see pressure. not saying that cranking isnt building, but it is electronic sending a signal. you may want to save some cash after running synthetic for a while, and not run rev-x.... it has helped, but once the crud is gone and the synthetic lubes the injector, you shouldnt need everytime.
Reply With Quote Quick reply to this message
  #4  
Old 10-15-2012, 10:40 AM
Super Moderator


 

Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,973
Thanks: 3
Thanked 30 Times in 16 Posts
Feedback Score: 3 reviews
Quote:
Originally Posted by shawnb99 View Post
most dummy lights wont move till they see pressure. not saying that cranking isnt building, but it is electronic sending a signal. you may want to save some cash after running synthetic for a while, and not run rev-x.... it has helped, but once the crud is gone and the synthetic lubes the injector, you shouldnt need everytime.
I agree with this.
Reply With Quote Quick reply to this message
  #5  
Old 10-15-2012, 02:39 PM
...swamp trash...
 

Join Date: Apr 2012
Location: Lake Worth
Posts: 2,268
Thanks: 77
Thanked 110 Times in 85 Posts
Feedback Score: 1 reviews
Yes I agree with you guys on the Rev X. I don't plan on using it consistantly. I understand it is just a cleanser I thought about running Archoil after after that because what I read it's a friction modifier. I know those dash gauges aren't very accurate, I rely more on my Edge than anything because it pulls info straight from the pcm. The reason I ask about the dummy gauge is that I see the question come up when people have these "no start or hard start" situations. Somebody always chimes in and asks the op if it moves while cranking. Thanks for the advice guys!
Reply With Quote Quick reply to this message
  #6  
Old 10-16-2012, 03:53 AM
...swamp trash...
 

Join Date: Apr 2012
Location: Lake Worth
Posts: 2,268
Thanks: 77
Thanked 110 Times in 85 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by southend View Post
First off, my icp is .8 - .9 at idle, I think your right on your thinking. And I found this is why my dash guage doesn't jump up quickly, check it out.......Questions? Oil filter housing is dry. With pics. - Ford Powerstroke Diesel Forum

Sent from my phone that somebody didn't help me get.
Read your writeup Southend, did you ever get your drain back issue solved? Something to think about, kinda want to check mine. Like you mine sits a lot but gets run hard on the weekend.
Reply With Quote Quick reply to this message
  #7  
Old 10-16-2012, 04:20 AM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Quote:
Originally Posted by Merc82 View Post
Read your writeup Southend, did you ever get your drain back issue solved? Something to think about, kinda want to check mine. Like you mine sits a lot but gets run hard on the weekend.
No, it has to be the anti drain back valve allowing the oil to drain. Theres no spring pressure on it, bad design, imo. I would have to change the oil cooler cover because the valve is not available separately. Also I can see the little valve is in good shape, it's where it seats thats chewed up a bit. If I change it, I will definetly update.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:22 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors