03 6.0 EGR DELETE question - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-04-2012, 02:18 PM
Member
 

Join Date: Dec 2009
Location: North Mississippi
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
03 6.0 EGR DELETE question

Sorry if been asked before....I've searched threads after threads and have come up with a wide variety of answers most of which were from a few years back. Thought someone might have a more up to date definitive answer. I have an 03 6.0 that I just put a Sinister EGR delete kit in. I noticed turbo seemed quieter and VGT solenoid makes a funny sound. Truck runs fine and no CEL but does throw a couple codes 0401 and 0403 I believe. Boost doesn't seem to get over 20 psi at WOT. Otherwise runs fine or at least seems too. Is this normal or as I've read in other post getting a custome tune with SCT you can eliminate the EGR function totally? With it in its current state could the turbo not cycle correctly with th EGR unplugged? What direction should I go in? Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-04-2012, 03:34 PM
Premium Member
 

Join Date: Feb 2011
Location: Edmonton, Alberta Canada
Posts: 3,944
Thanks: 0
Thanked 31 Times in 30 Posts
Feedback Score: 1 reviews
Some PCM flash versions have issues if the EGR valve is electrically disconnected such as the fan clutch not being able to reach maximum engagement and also issues with the turbo vane startup stroke. IMO either leave the EGR valve in and do a "sneaky" delete or do a full delete and use the right rear intake elbow bolt going threw the mounting tab of the EGR valve to hold it from bouncing around on top of your engine.

Last edited by Term3; 10-04-2012 at 03:39 PM.
Reply With Quote Quick reply to this message
  #3  
Old 10-04-2012, 04:30 PM
Member
 

Join Date: Dec 2009
Location: North Mississippi
Posts: 48
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yeah I did the complete delete. Had a new hpop and cooler installed...had shop put complete delete in while they had everything apart. I tried plugging in egr valve and laying it on top but it appears shop didn't give my original egr valve back. And this one has a problem ...throws a code (don't remember) something about turbo power??? Or something like that. Ill stop by shop and ask for my original egr valve back tomorrow. If I buy a SCT will a custom tune be able to be written in which the turbo will work properly without having an egr valve plugged in?
Reply With Quote Quick reply to this message
  #4  
Old 10-04-2012, 04:42 PM
Premium Member
 

Join Date: Feb 2011
Location: Edmonton, Alberta Canada
Posts: 3,944
Thanks: 0
Thanked 31 Times in 30 Posts
Feedback Score: 1 reviews
To my knowledge there is no tune that takes care of that issue if your truck has the flash version issue.
Reply With Quote Quick reply to this message
  #5  
Old 10-04-2012, 05:04 PM
Compression Ignition Addict
 

Join Date: Jun 2012
Location: O'Fallon,Mo
Posts: 845
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
i may be mistaken, but a tune writer can select what ever strategy they feel works best with their tune..... buy an sct from the likes of GEARHEAD AUTO or QUICK TRICKS AUTO, these twqo seem to be very reputable and highly spoken for when it comes to tuning the 6.0. they will get your problem fixed.
Reply With Quote Quick reply to this message
  #6  
Old 10-04-2012, 07:06 PM
Premium Member
 

Join Date: Jan 2012
Location: Fallon, Nv
Posts: 2,402
Thanks: 52
Thanked 9 Times in 8 Posts
Feedback Score: 0 reviews
I have an 03, when I removed the valve (intake swap a few months after removing just the EGR cooler), my 03 did about the same as the O.P.'s. I went to a local diesel repair shop and got a used EGR valve (FREE), plugged it in, laid it on the intake, VIOLA! It seems that certain strategies are effected by the valve removal, some aren't. Although I do plan to stuff it in the hole because it looks tacky hanging there like that.

MAtt from Gear Heads was the one who told me to get another valve, used or otherwise. If you hooked up a used one, and it didn't work for you (it actually took a day or two for things to get back to normal), I'd find another used one.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:42 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors