Low idle and won't rev up when I'm pressing the gas pedal. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-07-2012, 09:13 AM
Powerstroke.org Rookie
 

Join Date: Feb 2012
Location: Manhattan
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Low idle and won't rev up when I'm pressing the gas pedal.

So at first I thought it was a problem with my fuel pick up hose, since it only did it while I was below a 1/4 but then yesterday it did it again and it was over 3/4 full. So what happens is I'll start it up and if it idles to long (usually while waiting on the wife) the idle will drop to just above 500 (just below 750 normal) and no matter how long I floor it for it will not rev up. Sometimes it will snap out of it but usually I have to shut it off and restart it. It sounds to me like the fuel filter needs to be replaced. But I figured I'd ask first.

Oh and where is the fuel filter on my 05 f250 ccsb 6.0 L
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-07-2012, 09:26 AM
Compression Ignition Addict
 

Join Date: Sep 2011
Location: Newellton, LA
Posts: 1,249
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
That would be a great place to start. When you pop the Hood and look at the top of the motor, you will see two black plastic tops that look like you can put a socket on them. The oil filter is on the left and fuel filter is on right. That is the secondary filter, the primary filter is under the truck in the pump. It is located on the inside frame rail right under the front of the drivers side door. When you look at the pump from the rear of truck you will see another one of those black plastic caps that you can put a socket on. There will be a place for a socket and a place for an extension to get them off, use the socket. You can crack the caps trying to use the extension.

Sent from my DROID RAZR using AutoGuide App
Reply With Quote Quick reply to this message
  #3  
Old 09-07-2012, 09:35 AM
Compression Ignition Addict
 

Join Date: Mar 2010
Posts: 189
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Does it smoke?

Mine does the same thing and smokes when the EGR valve needs a good cleaning.
Reply With Quote Quick reply to this message
  #4  
Old 09-07-2012, 09:36 AM
Compression Ignition Addict
 

Join Date: Sep 2011
Location: Newellton, LA
Posts: 1,249
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Do you have any gauges like a CTS or a scangauge?

Sent from my DROID RAZR using AutoGuide App
Reply With Quote Quick reply to this message
  #5  
Old 09-07-2012, 09:46 AM
Powerstroke.org Rookie
 

Join Date: Feb 2012
Location: Manhattan
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thank you, no I don't have any yet.

The only time it rolls coal is when I romp on it from a stop, or pull some one out of the mud.
Reply With Quote Quick reply to this message
  #6  
Old 09-07-2012, 09:47 AM
Powerstroke.org Rookie
 

Join Date: Feb 2012
Location: Manhattan
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
But I also have a 4in. Straight pipe from the turbo back.
Reply With Quote Quick reply to this message
  #7  
Old 09-07-2012, 09:49 AM
Premium Member

 

Join Date: Jul 2011
Posts: 401
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I could possibly be a bad connection of the accelerator pedal. These engines are drive by wire. The fact that it runs but won't do anything else would lead me to the accel pedal.

Dik
Reply With Quote Quick reply to this message
  #8  
Old 09-07-2012, 09:51 AM
Powerstroke.org Rookie
 

Join Date: Feb 2012
Location: Manhattan
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
But before it happens the idle drops to just over 500
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:42 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors