Holy dirt in coolant filter! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-24-2012, 08:05 PM
Member
 

Join Date: Jan 2010
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Holy dirt in coolant filter!

I just cut open a coolant filter after 15k miles and had over 1/4 cup of casting sand and junk in it! I changed my first one at 10k of usage and it had nearly the same amount! I can email pics to anyone who wants to post them for me. I can post them from my phone.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-25-2012, 05:29 AM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I'll pm you, i'll post em.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #3  
Old 08-25-2012, 05:58 AM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Holy cow, is right!




Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #4  
Old 08-25-2012, 06:00 AM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Are you monitoring deltas? What kind of coolant filter are you running?

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #5  
Old 08-25-2012, 06:07 AM
Member
 

Join Date: Jan 2010
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I run the filter from diesel site.com I have the edge CTS and my monitor my deltas. I was seeing 10-15 unloaded and 30+ towing. I just replaced oil cooler and installed a bulletproof EGR cooler last week. The filters are the Baldwin ones. I ditched the gold for cat ELC this time.
Reply With Quote Quick reply to this message
  #6  
Old 08-25-2012, 06:32 AM
Compression Ignition Addict
 

Join Date: Sep 2010
Location: Merrimack NH
Posts: 251
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
damn! glad im running my coolant filter too.. i run the napa 4070 filter. First time i didn't get much for casting sand though.. prolly because i did the flush shortly before it
Reply With Quote Quick reply to this message
  #7  
Old 08-25-2012, 06:41 AM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
I'm waiting on my coolant filter, been on backorder for a month, supposed to ship monday. I've got 24 delta after a serious tap water and distilled flush. Refilled with elc.

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #8  
Old 08-25-2012, 06:56 AM
Premium Member
 

Join Date: Feb 2011
Location: Edmonton, Alberta Canada
Posts: 3,941
Thanks: 0
Thanked 31 Times in 30 Posts
Feedback Score: 1 reviews
So you got that amount of crap in your filter before or after you switched to ELC?
Reply With Quote Quick reply to this message
  #9  
Old 08-25-2012, 07:05 AM
Member
 

Join Date: Jan 2010
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I switched to ELC the same time I changed the filter. ELC never ran through this filter
Reply With Quote Quick reply to this message
  #10  
Old 08-25-2012, 09:02 AM
War is the answer!


 

Join Date: Feb 2011
Location: Daytona Beach, Florida
Posts: 5,046
Thanks: 101
Thanked 64 Times in 19 Posts
Feedback Score: 2 reviews
I did a compleat and thurow flush less than a year ago also changing out my oil cooler but I changed my coolant filter out today and holly sh1t was there a lot of crap in there.

Sent from my GSIII on the Blazer ROM LF8 Radio.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:37 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors