Bad fuel or oil change?? 6.0 running bad. - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-14-2012, 08:14 PM
Friend of Dr.Bob
 

Join Date: Nov 2011
Location: Mount Vernon,WA
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Bad fuel or oil change?? 6.0 running bad.

I changed oil yesterday. Did nothing out of the ordinary. New oil, same T6 as before. Same oil filter. Filter snapped into cap just fine. New O ring on cap. Dumped in 14 qts. Fired it up with no leaks. Drove home.

This morning started truck and I noticed it stumbled while idling. I let it warm for a minute, then proceeded to chug up the hill as normal. It ran bad till warm. By the time I got to the interstate (4 mi) it seemed back to normal.

Then I started it again tonight,noticed it stumbling again, wife even said something doesnt sound normal. This time I gave it some throttle going up the hill, enough to where gravel should have been flying with wheels spinning, and it only revved to maybe 1500 rpm.

So, the only thing I can think of oil change-wise is a oil pressure leak around the cap.

Or....(this just dawned on me)..BAD FUEL! Just remembered I filled up with 26 gallons yesterday right after I changed oil. Just checked the slip and diesel fuel was used..*WHEW*..Oregon sucks as far as not being able to pump your own.

My moneys on the bad fuel.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-14-2012, 08:23 PM
Powerstroke Techie

 

Join Date: Aug 2010
Location: Sassamansville, Pa
Posts: 9,732
Thanks: 93
Thanked 189 Times in 152 Posts
Feedback Score: 3 reviews
When was the last time you checked/cleaned the EGR valve? How's the fuel psi? '03's had issues with ICP going bad, oil leaking and damaged ICP wires. Just throwing it out there.
Reply With Quote Quick reply to this message
  #3  
Old 08-15-2012, 05:23 AM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Motorcraft filters AND cap?

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
  #4  
Old 08-15-2012, 05:28 AM
Compression Ignition Addict
 

Join Date: Jul 2007
Location: nj
Posts: 1,273
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Can't hurt changing the fuel filters. And drain the water/fuel seperator as well and see if that works.
Reply With Quote Quick reply to this message
  #5  
Old 08-15-2012, 05:32 AM
Compression Ignition Addict
 

Join Date: Aug 2012
Posts: 276
Thanks: 5
Thanked 9 Times in 8 Posts
Feedback Score: 0 reviews
From what you describe my money is on bad fuel also. Just because the tag says diesel doesn't mean it is. Pull the cap and smell your fuel.
Reply With Quote Quick reply to this message
  #6  
Old 08-15-2012, 06:30 AM
Friend of Dr.Bob
 

Join Date: Nov 2011
Location: Mount Vernon,WA
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ford cap and filters. Just changed both fuel filters around a month ago,drained the fuel separator.

As far as bad fuel goes, would it be beneficial to get some cetane booster? I don't use any fuel additive.

We are going on a 250 mile trip today. Hope everything holds together! I ll get some different fuel tonite.
Reply With Quote Quick reply to this message
  #7  
Old 08-15-2012, 07:59 AM
Member
 

Join Date: Aug 2010
Posts: 47
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Mine does the same thing. Runs like crap till she warms up. I have had it on a scan tool several times, everything checks out. I know your pain. Very puzzling.

Sent from my LG-P925 using AutoGuide.Com Free App
Reply With Quote Quick reply to this message
  #8  
Old 08-15-2012, 05:51 PM
Premium Member
 

Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
Quote:
Originally Posted by baldguy2001 View Post
Mine does the same thing. Runs like crap till she warms up. I have had it on a scan tool several times, everything checks out. I know your pain. Very puzzling.

Sent from my LG-P925 using AutoGuide.Com Free App
What kind of scan tool?

Sent from my phone that somebody didn't help me get.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:05 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors