2005 6.0L stalls all the time, hard starting also - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-11-2012, 05:33 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Location: New Brunswick, Canada
Posts: 774
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
2005 6.0L stalls all the time, hard starting also

Checked everything on this truck, FiCM 48V, ICP 685 Idling, EGR was stuck at zero but bounced back after hard reving, Cleaned EGR Valve and it was not very dirty. Turbo ran up to 32PSI.

I am leaning toward the Campshaft sensor, or the STC fitting.

This a friend's truck and he has been trying to get rid of it, and I am try to encourage him to keep it, for the value he is getting in trade is very low.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-11-2012, 05:56 PM
Banned
 

Join Date: Oct 2011
Location: Carrollton Ohio
Posts: 8,839
Thanks: 65
Thanked 58 Times in 40 Posts
Feedback Score: 10 reviews
You have good values so far but what are they when it off and trying to start?
Reply With Quote Quick reply to this message
  #3  
Old 08-11-2012, 06:05 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Location: New Brunswick, Canada
Posts: 774
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
They were read when the truck was not starting and after it started the EGR was stuck on zero and after reving it to 3000RPM for a bit it went to normal. That was my test and now he has the truck and driving it like that, mad as h..l. I would like to help him, I changed the FICM last fall, and the EOT has been good, with ELC-1 Flush. Actually if I floored it it stalls on rev-down. Compared it to mine, his Turbo Goes higher but I felt that the ICP was low I never saw 1000PSI. He has an Air Raid filter setup, and there is an air filter message in the dash that I can't cancel, and no codes.

Last edited by caissiel; 08-11-2012 at 06:14 PM.
Reply With Quote Quick reply to this message
  #4  
Old 08-11-2012, 06:10 PM
Banned
 

Join Date: Oct 2011
Location: Carrollton Ohio
Posts: 8,839
Thanks: 65
Thanked 58 Times in 40 Posts
Feedback Score: 10 reviews
Quote:
Originally Posted by caissiel View Post
Checked everything on this truck, FiCM 48V, ICP 685 Idling, EGR was stuck at zero but bounced back after hard reving, Cleaned EGR Valve and it was not very dirty. Turbo ran up to 32PSI.

I am leaning toward the Campshaft sensor, or the STC fitting.

This a friend's truck and he has been trying to get rid of it, and I am try to encourage him to keep it, for the value he is getting in trade is very low.
You said it was running for these tests. Take readings of ICP actual and desired as well as IPR % actual and desired while cranking. what all does your friend have done to the truck we need more info on the vehicle before we can really help. Also what are you using to get these readings?
Reply With Quote Quick reply to this message
  #5  
Old 08-11-2012, 09:13 PM
Member
 

Join Date: Jan 2012
Location: Fort Saint John
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
the air filter message on his dash is probably from the filter minder, my minder kicked rocks a couple months ago and i got the message, un-plugged the wires running to it and no more "check air filter" message.
Reply With Quote Quick reply to this message
  #6  
Old 08-26-2012, 05:57 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Location: New Brunswick, Canada
Posts: 774
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I will be checking the truck again on thursday and report back. Thanks for the previous answers. We are checking prices for CMP and IPR, I have a scangauge II programed for my 6.0L.
Reply With Quote Quick reply to this message
  #7  
Old 08-29-2012, 04:14 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Location: New Brunswick, Canada
Posts: 774
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Just drove the truck home.

Started right up with pressure on accelarator, but stalls all of a sudden at Idle only.

Some readings on the scangauge.
Idling: ICP 585, IPR 21.5 PID list desired as 625/24
Idling at 1100 RPM: ICP 680 IPR 23 PID list desired as 1400-1450/40.60
No codes

Running down the road at 50MPH, RPM 2000, ICP 2000-2500,

My Truck ICP is 940 at idle or just after start, I have been comparing his reading to mine and they are definitly different specialy ICP readings but it starts good

Did not check the load but the trucks felt it was out of power. But the rims get hot from brake rub on the disks.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:17 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors