Few Codes and electrical problems - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-06-2012, 12:22 PM
Powerstroke.org Fanatic
 

Join Date: Nov 2008
Location: San Antonio
Posts: 134
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Few Codes and electrical problems

Alright so the engine light came on the other day with these codes
2005 F-250 KR

p0046 : No Turbo Boost‎
&
p0673 : Glow plug #3 circuit failureCircuit

Not sure if there related or not but I've just replaced all cac boots & holes clamps checked for leaks coming off the turbo and around the lower side.

The corrector that goes to the VGT solenoid it dose not click in to place. I've pulled over many of times to check if its still in place and its seems fine.

While driving the truck the boost will work fine @ high speeds but at low it reads 0 or works when it wants to. (thinking the VGT solenoid is going out or the pigtail or the vanes are sticking) Just had the turbo cleaned 6 months ago.

Now to the electrical problems

TBC Fault -Check the fuses, Comes on all the time when i start the truck or randomly comes on while driving. The harness that connect to the trailer seems fine trailer lights work fine but the TBC will not work. & No blown fuses


Fog Lights -check volts on connector no volts. lights are brand new OEM & No blown fuses
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-15-2012, 03:30 PM
Powerstroke.org Fanatic
 

Join Date: Nov 2008
Location: San Antonio
Posts: 134
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Took the truck to the shop and they fixed the glow plug and told me that my injectors were bad they shiped them to houston to be flow tested came back 4 are shot and other 4 bearly passed had them replace all 8 injectors to save the time and money of them doing the job all over again they could not find a problem with the P0046 code.

The fog lights had a grounding problem... Fixed for about 2 days
TBC - Works fine for them just says TBC fault on the display

3 days after I get the truck out and i'm out of town the P0046 code comes back and would lose boost randomly called the shop guy says bring it back in. Get back in town I dont clear the codes so he can see it, guy calls me back saying there's nothing wrong.

How? the hell can nothing be wrong when the engine light comes on you can see the code on the CTS and the truck is runing like A$$. So while its in there I Tell them to replace the VGT solenoid & pigtail

Last edited by dlsanders6oh; 08-15-2012 at 03:34 PM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:50 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors