Question for those with Edge CTS - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 07-05-2012, 02:31 PM Thread Starter Rookie
04PSDF350's Avatar
Join Date: Jul 2012
Posts: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question for those with Edge CTS

I just got mine and installed it today. Works and looks great but in looking in the diagnostics menu the injector balance option is missing. Any ideas?

On a positive note deltas are 6-8 degrees in 101 heat. For what is worth, I didnt know what a delta was until a day or two ago. Haha

2004 F350 Lariat PSD CC SRW
Medium Wedgewood Metallic Blue/Arizona Beige
Big Tex Grill Guard
Leveling Kit
35x12.5 Federal Couragia M/Ts
20" Eagle Alloy wheels
EGR Delete
High Idle switch
Edge Insight CTS
5" DiamondEye Turbo Back Off Road exhaust
Recently cleaned turbo which I did myself and I am quite proud of (:
04PSDF350 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome