HIDs wont stay on???HELP - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 06-30-2012, 10:27 PM Thread Starter
Compression Ignition Addict
 
lowrider284's Avatar
 
Join Date: Jun 2011
Location: Paramus NJ
Posts: 613
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
HIDs wont stay on???HELP

Hey guys finally got around to attempt to installing my DDM tuning hid kit. I got everything hooked up and the bulbs were fine. the second time and every time after that i turn on the headlights and they will flick on for maybe a second then go out.
lowrider284 is offline  
post #2 of 11 Old 07-01-2012, 04:58 AM
Powerstroke.org Rookie
 
Join Date: Feb 2010
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Do you have the constant power wire ran? Mine do this so I called and they send me the wire. It should fix your problem.

2006 F250 6.0 with level kit, 35'' mud country's, 5'' exhaust, bully dog intake, edge cts, banjo bolt mod, blue spring, and a mad turbo on the way.
curcio13085 is offline  
post #3 of 11 Old 07-01-2012, 10:08 AM Thread Starter
Compression Ignition Addict
 
lowrider284's Avatar
 
Join Date: Jun 2011
Location: Paramus NJ
Posts: 613
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
You mean a relay?
lowrider284 is offline  
post #4 of 11 Old 07-01-2012, 05:50 PM
Compression Ignition Addict
 
elm302's Avatar
 
Join Date: Jun 2009
Location: monett Missouri
Posts: 1,915
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 3 reviews
I had the same problem with Ddm kit ended up being bulbs. They sent me new ones to replace them. Keep in mind the bulbs were brand new and still didn't work.

2003 F350 Lariet Leveling kit eagle 197s MBRP stainless tb to 6" stack Sinister coolant kit Sct with Looney and Innovative High Idle fog light and bright box mod soon to come Edge CTS PHP ficm tuning and Cab lights
elm302 is offline  
post #5 of 11 Old 07-01-2012, 05:51 PM
Compression Ignition Addict
 
elm302's Avatar
 
Join Date: Jun 2009
Location: monett Missouri
Posts: 1,915
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 3 reviews
Almost sounds like a ballast issue too. Swap everything around and see if you can pin point the problem

2003 F350 Lariet Leveling kit eagle 197s MBRP stainless tb to 6" stack Sinister coolant kit Sct with Looney and Innovative High Idle fog light and bright box mod soon to come Edge CTS PHP ficm tuning and Cab lights
elm302 is offline  
post #6 of 11 Old 07-01-2012, 06:01 PM Thread Starter
Compression Ignition Addict
 
lowrider284's Avatar
 
Join Date: Jun 2011
Location: Paramus NJ
Posts: 613
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
I had the raptor kit hooked up maybe ill use the slim ballasts i ordered for my fogs
lowrider284 is offline  
post #7 of 11 Old 07-01-2012, 06:12 PM Thread Starter
Compression Ignition Addict
 
lowrider284's Avatar
 
Join Date: Jun 2011
Location: Paramus NJ
Posts: 613
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Should i buy the relay?
lowrider284 is offline  
post #8 of 11 Old 07-01-2012, 10:56 PM Thread Starter
Compression Ignition Addict
 
lowrider284's Avatar
 
Join Date: Jun 2011
Location: Paramus NJ
Posts: 613
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Ok got some good news and bad news, used my fog slim ballasts for my headlights and both work fine now. For the hell of it i used the raptors i originally tried for the headlights for the fogs and both worked even tho one of the ballasts didn't work for the headlights last night. Then the same thing happened with the fogs as the headlights, the one ballast worked fine on startup then every-time after that it didn't work. I tried one of the slim ballasts and the light worked fine so i know its not the bulb. Would the ballast be broken but be able to do that twice? (be fine the first time used on a bulb but every-time after that only flicker and not stay on)
Attached Thumbnails
Click image for larger version

Name:	IMG_1696.jpg
Views:	316
Size:	92.4 KB
ID:	39733   Click image for larger version

Name:	IMG_1695.jpg
Views:	101
Size:	96.2 KB
ID:	39734  

Last edited by lowrider284; 07-01-2012 at 11:14 PM.
lowrider284 is offline  
post #9 of 11 Old 07-02-2012, 12:36 AM
Premium Member
 
Join Date: May 2011
Location: Lafayette, Indiana
Posts: 654
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Feedback Score: 0 reviews
I'm not going to lie. I had the same problem with my HID kit. I had the slim kit and my left one would turn on the off. So I turned my lights on before I started the truck. Worked fine, I'm guessing it surged too much to give it the power it needed. Idk. It was either that or left the lights off, then pull the brights on manually to see if they stayed on. If they did I switched the headlights on then let go of the brights.

That's why I ditched the HIDs. I might try the retro-solutions kit down the road, until then my halogens will work.

1999 F-350 ECSB ZF6 4x4 Halfbreed:
Mods:
PHP Pheonix 6-Position Chip
Glowshift gauges (boost/egts/oil psi/fuel psi/oil temp/coolant temp/voltage
DIY 6637 Intake
5" Diamond Eye exhaust
05+ Harley Davidson Headlights
55w 5000K HIDs
Future Mods:
Shocker horns
SRP1.1
Irate turbo setup
S366
DIY fuel system with regulated return
and saving to build a mid 500hp rig.
stroker0920 is offline  
post #10 of 11 Old 07-02-2012, 01:31 AM Thread Starter
Compression Ignition Addict
 
lowrider284's Avatar
 
Join Date: Jun 2011
Location: Paramus NJ
Posts: 613
Thanks: 8
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
im going to call ddm and return the two raptor ballasts and get 2 slims anyway since i need the mounting holes to secure them
lowrider284 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome