In desperate need of A/C help - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 2 Old 06-23-2012, 05:47 AM Thread Starter
Compression Ignition Addict
Fox'sFord's Avatar
Join Date: Oct 2010
Location: Chestertown Md
Posts: 301
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
In desperate need of A/C help

Here's the problem, when the system isn't charged everything works fine, except the important part- no cold air. When a charge is added it blows the 15 amp fuse almost immediately. When you put a 20 amp fuse in the blower comes on but it won't engage the clutch on the compressor, and the wiring harness under the hood gets hot to the touch. Already started throwing parts at the problem, replaced the compressor and clutch assembly, and low limit switch. Same results, gotta be in the wiring right? Everything was in good working order before lifting the cab for studs this winter. I'm thinking something got pinched during the process, but have no idea where to look.

Any help would be greatly appreciated, Maryland summers are humid, and I'm in this truck 4hrs

Truck is xlt with manual controls.

06 F250 leveled on 35's, studded, deleted, Innovative, 4" straight pipe, banjos, spring, ccv w/can, elc w/ filter, DVD/sat/nav in dash, kr running boards, bull bar

Fox'sFord is offline  
Sponsored Links
post #2 of 2 Old 06-23-2012, 07:32 AM
Premium Member
southend's Avatar
Join Date: Jan 2012
Location: Gulf Coast
Posts: 5,201
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 1 reviews
You need to check the hot wire to the compressor. It is grounded, it also runs through the high and low pressure switches. Or you forgot to hook a ground up somewhere?

Sent from my SCH-I500

Unfortunately had to Sell my ......2004 KR CC SWB FX4 - Edge insight cts, blue spring upgrade, updated HFCM drain plug, XDP coolant filter, CAT EC-1 rated coolant, Custom Diesel EGR delete, CAT delete, Rotella T6

southend is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome