Can't catch a break - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-18-2012, 08:14 AM
Compression Ignition Addict
 

Join Date: Feb 2011
Posts: 295
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Can't catch a break

I just can not catch a break with this truck. I bought it in early feb. I had the truck for a week and the turbo was sticking. So I figured no big deal I will pull it off and clean it up. Well when I had it off I noticed the turbo had fins missing bla bla bla.. Ok fine. I ordered a new turbo. Two days after I had the new turbo on driving down the road everything normal she just shuts down. Im on the side of the road with oil gushing out of the motor. I crank on it a little and notice a loud clunking sound. My heart drops.. '

So about 2 weeks go by and I can't figure it out. I had a good idea what it was but didn't want to believe it. Yep my motor is toasted. Had a broked crank. Snapped in two. So few more weeks go by i hussle up enough cash for a longblock. Longblock arrives and i get it installed.. Finially I have a truck thats running again.. Puuurrrs like a kitten.. So i have been just taking it easy on her to break the new motor in nicely. Today I was out changing a rear caliper since it was sticking.. Everything went straight forward for once and im all excited.. So i take her for test drive. And what do you know.. The damn turbo is sticking again! WTF it has less the 300 miles on it..

I know these turbos like to stick and im ok with that. I don't mind wrenching on my truck from time to time. BUT what gets me is I just put this thing on a few months ago. It was running great for 120 miles since I got it running again. Now this. I just can't catch a break with my lovely 6.0.. I do love the truck and love the power it makes.. But damn somedays it just tears me up..

sorry for long rant.. I emailed the company I received the turbo from and shall see what i need to do from here.. Im sure it just needs a cleaning but i should have to do that with one that has less then 300 miles. Am i wrong for thinking that?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-18-2012, 08:18 AM
Serving Our Country!

 

Join Date: Jan 2010
Location: League City, TX
Posts: 1,245
Thanks: 0
Thanked 3 Times in 3 Posts
Feedback Score: 5 reviews
Dang man that sucks. It shouldn't have any problems with that low of mileage
Reply With Quote Quick reply to this message
  #3  
Old 06-18-2012, 08:20 AM
Premium Member



 

Join Date: Dec 2011
Location: Spokane, WA
Posts: 17,927
Thanks: 74
Thanked 117 Times in 108 Posts
Feedback Score: 5 reviews
If the turbo is sticking, then no you are not wrong for thinking that...


But, how do you know it is the turbo?
Reply With Quote Quick reply to this message
  #4  
Old 06-18-2012, 08:25 AM
Compression Ignition Addict
 

Join Date: Feb 2011
Posts: 295
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
i think its the turbo becaue it will go in and out of building boost.. Feels like it will spit and sputter.. Has new ficm, icp, ipr, glow plugs, and y pipe.. don't know what else it would be
Reply With Quote Quick reply to this message
  #5  
Old 06-18-2012, 08:41 AM
Premium Member



 

Join Date: Dec 2011
Location: Spokane, WA
Posts: 17,927
Thanks: 74
Thanked 117 Times in 108 Posts
Feedback Score: 5 reviews
Have you tried scanning it with an AE?

I can't think of it right now, but I don't think it is a sticking turbo... When my turbo was sticking/ stuck It would just take a REALLY long time to spool and wouldn't have enough power ever. This sounds like something else... (Maybe)

But I would scan it
Reply With Quote Quick reply to this message
  #6  
Old 06-18-2012, 11:25 AM
Compression Ignition Addict
 

Join Date: Feb 2011
Posts: 295
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
here are the codes.. I still havn't looked to see what they mean yet.

p0237
p0403
p0405
p0683
Reply With Quote Quick reply to this message
  #7  
Old 06-18-2012, 12:59 PM
Compression Ignition Addict
 

Join Date: Feb 2011
Posts: 295
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
would maybe the map sensor have something to do with this? its like in and out of power. so if feels like its spitting and sputtering
Reply With Quote Quick reply to this message
  #8  
Old 06-18-2012, 01:24 PM
Premium Member
 

Join Date: Aug 2011
Location: Park City, UT
Posts: 561
Thanks: 1
Thanked 6 Times in 4 Posts
Feedback Score: 0 reviews
EGR valve?
Reply With Quote Quick reply to this message
  #9  
Old 06-18-2012, 01:40 PM
Compression Ignition Addict
 

Join Date: Feb 2011
Posts: 295
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
prolly should of said something.. truck is deleted.. i just cleaned the map sensor and it ran fine after that for awhile. then back to the same old song and dance.. i guess im leaning towards the map sensor then.
Reply With Quote Quick reply to this message
  #10  
Old 06-18-2012, 06:33 PM
Compression Ignition Addict
 

Join Date: Feb 2011
Posts: 295
Thanks: 3
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
anyone else have any imput?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:46 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors