Idle surge - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-02-2012, 07:07 PM
Member
 

Join Date: Feb 2012
Location: Fresno, ca
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Idle surge

I have a 04 f250 I was leaving stop light and at low steay speed and my idle jumped up and the truck spead up for split second then normal. Did it two short times. What could this be? I wanna find it before anything happens
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-03-2012, 08:47 AM
Compression Ignition Addict
 

Join Date: Jan 2008
Posts: 2,116
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Same symptoms on my dad's '03 ended up being the ICP sensor.
Reply With Quote Quick reply to this message
  #3  
Old 04-03-2012, 08:56 AM
Premium Member
 

Join Date: Oct 2010
Posts: 1,956
Thanks: 0
Thanked 21 Times in 19 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by cartmanea View Post
Same symptoms on my dad's '03 ended up being the ICP sensor.
Yep ICP sensor or wiring to sensor.
Reply With Quote Quick reply to this message
  #4  
Old 04-03-2012, 09:49 PM
Member
 

Join Date: Feb 2012
Location: Fresno, ca
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
it happened to me again today seems when i get of freeway it does it. was little more today tho i tried to die then jumped back up to little higher rpm
Reply With Quote Quick reply to this message
  #5  
Old 04-09-2012, 04:54 AM
Powerstroke.org Rookie
 

Join Date: Aug 2010
Location: Napa ca
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mines doing the same. Just tagging your post to get answers myself
Reply With Quote Quick reply to this message
  #6  
Old 04-09-2012, 04:56 AM
Powerstroke.org Rookie
 

Join Date: Apr 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine did the exact same thing. Had the ICP sensor changed. Check pigtail for oil. Should be fine if it's dry and just change sensor


Sent from my Autoguide iPhone app
Reply With Quote Quick reply to this message
  #7  
Old 04-24-2012, 06:57 PM
Member
 

Join Date: Feb 2012
Location: Fresno, ca
Posts: 84
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
does any one have a pic where the sensor is located?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:09 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors