clearance lights - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 03-27-2012, 09:51 PM Thread Starter
Powerstroke.org Fanatic
 
jordan07's Avatar
 
Join Date: Jan 2012
Location: Celina ohio
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
clearance lights

ok so my clearance lights the very end ones so far left and far right ones dont work put new bulbs in made sure the contacts and wires all look good and they do but the 3 middle light s work ? any ideas?
jordan07 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 03-28-2012, 02:37 AM
Compression Ignition Addict
 
Join Date: Oct 2010
Location: Deerfield, VA
Posts: 434
Thanks: 8
Thanked 11 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I've installed a factory set on an earlier F-series, here is what I learned, each light is "pigtailed" on the harness, so there is a connector for each light. You may have a corroded connection, if it's corroded, you may have a water leak. I would pull down my headliner to be sure. And BTW, before you start tearing into things, did you check the bulb socket with a test light for power?

2004 F-250 XLT- FX4 - 4X4, Supercab, 8' bed, BRIGHT RED, Flint Gray Interior, 6.0 Torqshift
Sinister EGR Delete
Rotella ELC
Gutted throttle body
Coolant filter
Stator delete
Blue spring, 6.4 banjos
NChornet CCV mod
Rotella 5W-40 T-6 oil, Motorcraft filters
EDGE CTS monitor

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
DELTAJOHN is offline  
post #3 of 4 Old 03-28-2012, 10:20 AM Thread Starter
Powerstroke.org Fanatic
 
jordan07's Avatar
 
Join Date: Jan 2012
Location: Celina ohio
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
yes i put a test light on it shows no power?
jordan07 is offline  
post #4 of 4 Old 09-04-2012, 05:45 AM
Powerstroke.org Rookie
 
houston1987's Avatar
 
Join Date: Aug 2012
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Hey Jordan I know this post is from months ago but I am curious to know what was causing your clearance light issue??? I have an 07 350 srw bought about a month ago, clearance lights were working properly after purchase and just yesterday realized everyone of them was out.. I have not put a test light to one yet but plan on it very soon. Just wanted to get ideas from your experience!!!
houston1987 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome