Help me plz....no start...help help help - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 03-06-2012, 07:10 AM Thread Starter
Member
 
Join Date: Apr 2011
Posts: 52
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Help me plz....no start...help help help

Brief quick history and truck stats.
04 engine
had the truck a YEAR!
Mods- EGR delete, air intake, Predator tuner

Replaced the FICM first week i had the truck, along with the ICP sensor
Had the truck about a year and NOW BIG PROBLEMS

I have Brand new batteries ,
Throwing these codes....
-Cylinder 3 contribution and balance
-Glow plug 3 circuit
-glow plug 5 circuit
-glow plug 7 circuit
- ICP pressure too low ( i replaced the pig tail) still showing this code ( i heard it could be from just hittin the gas and releasing the pedal..i do it sometimes to black smoke haha


The truck is not starting . ..it will turn but will not fire....eventually after 20 times it will fire ...but it miss fires....

I need help...once it starts it runs fine....plz help me....

what do i need?????
Guitarhead09 is offline  
post #2 of 5 Old 03-06-2012, 09:59 AM
Premium Member
 
Join Date: May 2011
Location: Irving TX
Posts: 244
Thanks: 6
Thanked 5 Times in 5 Posts
Mentioned: 0 Post(s)
Quoted: 11 Post(s)
Feedback Score: 1 reviews
Quote:
Originally Posted by Guitarhead09 View Post
Brief quick history and truck stats.
04 engine
had the truck a YEAR!
Mods- EGR delete, air intake, Predator tuner

Replaced the FICM first week i had the truck, along with the ICP sensor
Had the truck about a year and NOW BIG PROBLEMS

I have Brand new batteries ,
Throwing these codes....
-Cylinder 3 contribution and balance
-Glow plug 3 circuit
-glow plug 5 circuit
-glow plug 7 circuit
- ICP pressure too low ( i replaced the pig tail) still showing this code ( i heard it could be from just hittin the gas and releasing the pedal..i do it sometimes to black smoke haha


The truck is not starting . ..it will turn but will not fire....eventually after 20 times it will fire ...but it miss fires....

I need help...once it starts it runs fine....plz help me....

what do i need?????
That stuff is out of my range. But I bet if you didn't mention the black smoke thing you probably would've had a reply by now. Sorry JMO

2006 F-350 6.0 Fx4
EGR delete
Dieselsite Coolant bypass filter
Edge CTS Monitor
Blue spring
Rotella T-6
Updated STC HPOP Fitting
SCT Tuner w/ Matt's tunes & Chris
Atlas 40 FICM tune from Ed
225,000 miles
05 Pstroker is offline  
post #3 of 5 Old 03-07-2012, 02:25 PM
Premium Member
 
jensenrcng's Avatar
 
Join Date: May 2008
Location: surprise, az
Posts: 436
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Feedback Score: 0 reviews
My truck is doing the same thing. What ended up being your problem?

2015 F-250 4x4: SCT X4 Tuner, Custom Rowdy Racks Tunes, 5" Exhaust, S&B intake, H&S Intercooler Pipe, AMP Research Steps, Carli 4.5" Pintop w/Full Rear Deaver Springs, ICON Dual sterring Stabilizer, 18" BMF Black/Machined Novakanes w/ 37x13.50 TOYO MT, Mishimoto Aluminum Radiator & Thermostat, Driven Diesel Oil Pan, Mag-Hytec trans pan and rear dif, T-Rex Black Billet Grille
jensenrcng is offline  
post #4 of 5 Old 03-07-2012, 04:18 PM
Powerstroke.org Fanatic
 
Join Date: Dec 2011
Posts: 143
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I have never had the issue and my knowledge is from this site... but with your truck getting an ICP code, not starting and misfiring when it does start. I'm going to toss a guess out and say your HPOP is high tailing it. Are you able to read your ICP when you are cranking? you need at least 500psi to fire.

2004 f-350 scsb 5.4l
2004 f-550 rcdump 6.0l
full bulletproof with oil bypass filter. PMM coolant filter. Arp studs, OEM gaskets, all ford updates.
ddb maine is offline  
post #5 of 5 Old 03-07-2012, 04:19 PM
Premium Member



 
Join Date: Dec 2011
Location: Spokane, WA
Posts: 20,256
Thanks: 118
Thanked 179 Times in 169 Posts
Mentioned: 9 Post(s)
Quoted: 270 Post(s)
Feedback Score: 5 reviews
Check the screen on the IPR valve...

Make sure it is not clogged or broken

2005 F250 King Ranch Work Truck.

Studded and Deleted
175/30% Injectors from WARREN DIESEL!!
Barder Stage 2 Turbo
Warren Comp Tranny w/ PI TC
Six0~Stroker is online now  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome