Video - FICM Going....Gone - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-26-2012, 02:03 AM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,816
Thanks: 6
Thanked 32 Times in 23 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
Video - FICM Going....Gone

One of my best friends Marc told me about a year ago when we were BS'ing that I was "masking a problem".
He lives in Cali - I'm in TX. Alot of you know him - Master Diesel Tech - kick azz guy on top.

Damn if it didn't hit me. Friggin ficm wen't crap on me.

The guys at Full Metal Performance came out right away, got me fired up and to the shop.
Joe - thanks YOU being the first Dully to kick my azz!



And Josh - thank you for fixing the beast.





Most of Y'all know me, I'm a computer guy - Don't know crap about diesels other mine hauls azz. To see them hook my rig up and WATCH (LEARN) my ficm trying to work.......when the gas was on, it dropped off the screen. And I was back stock.
My rig is back.......damn......now I need tires again.

Thanks FMP!!!!!!!!!!!!!!!!!!!!!

ETA - yeah that was Joe kicking my butt, Josh was behind us in his bad azz rig.

Last edited by Rodslinger; 02-26-2012 at 02:13 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-26-2012, 03:56 AM
War is the answer!


 

Join Date: Feb 2011
Location: Daytona Beach, Florida
Posts: 5,040
Thanks: 101
Thanked 64 Times in 19 Posts
Feedback Score: 2 reviews
Wow that sucks. Glad you up and running again though.
Reply With Quote Quick reply to this message
  #3  
Old 02-26-2012, 04:56 AM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,816
Thanks: 6
Thanked 32 Times in 23 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
Thanks man - yeah I was dead stick and even when she would run it was like you hear when I got on her. Watching the diagnostic on the computer was awesome. I pulled the tune off, back stock and the ficm just dropped and couldn't keep up - what y'all hear is hot tuned so it damn sure wasn't keeping up.
Reply With Quote Quick reply to this message
  #4  
Old 02-26-2012, 05:19 AM
Almostdunfukinwidit


 

Join Date: Nov 2006
Location: Trempealeau, WI
Posts: 30,948
Thanks: 106
Thanked 88 Times in 82 Posts
Feedback Score: 0 reviews
Send a message via Yahoo to Dave
Mines on the way out too. Mine will only run like that when EOT is below 40 at this point. Gotta get it sent in one of these days
Reply With Quote Quick reply to this message
  #5  
Old 02-26-2012, 05:26 AM
Powerstroke Techie

 

Join Date: Aug 2010
Location: Sassamansville, Pa
Posts: 9,630
Thanks: 85
Thanked 180 Times in 144 Posts
Feedback Score: 3 reviews
Too bad the Livewire won't read FICMv, you would of caught the problem earlier. Good to hear its back and running strong again. Let's just hope it didn't cause harm to your injectors.
Reply With Quote Quick reply to this message
  #6  
Old 02-26-2012, 05:41 AM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,816
Thanks: 6
Thanked 32 Times in 23 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
Damn Dave I wish you lived closer. Marc told me - I didn't listen.
As long as I had her plugged in all was fine. I was just loosing power on the road. Yeah I was plugging my rig in the past few weeks when it was in the 60's just because I knew it would run.

When she was warm she was fine, cold - screwed. That video shows me loosing all power. The injectors on the computer were great - the ficm just "ok" until you gave it the pedal and then it dropped off of the screen.
Reply With Quote Quick reply to this message
  #7  
Old 02-26-2012, 05:46 AM
Gun Nut




 

Join Date: Jul 2005
Location: Katy, Texas
Posts: 13,816
Thanks: 6
Thanked 32 Times in 23 Posts
Feedback Score: 0 reviews
Send a message via AIM to Rodslinger
Quote:
Originally Posted by Lilpooh View Post
Too bad the Livewire won't read FICMv, you would of caught the problem earlier. Good to hear its back and running strong again. Let's just hope it didn't cause harm to your injectors.
Me too man - course it would give me an excuse to have my buddies at Full Metal Performance put in a larger set < insert hint here >
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:47 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors