Uncommon Problem? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-21-2012, 07:03 PM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Location: Lombard IL
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Uncommon Problem?

Well First off I started a thread in the 911 emergency section but I put that fire out. I have a 06' 6.0l, CC, 5"TB, Edge juice W/Attitude(I know its on its way out). I had a very small oil drip for the last year that about two weeks ago became reasonably larger (leak from what appeared to be the upper rear pass. side running down on the bell housing). Now for about the last 2 months it has had a longer crank time than before. Ok its on my to do list (when it gets warmer) Im heading home from work last Fri. and kaput. It cranks no start. I yank it back to my house with a buddys truck and take a look, when I crank its pissing oil!!! Ok I have a ICP sensor low pressure code, so Im thinking alright bad STC fitting due to the longer crank and what felt like its been a bit slugish btu I still cant figure out where its leaking from. I looked high and low on the forum and couldnt find anything about the problems I am having. I tore into it on Sun. and I found a blown out STC fitting and the what seems to be the worst possible situation the rear engine cover it cracked due to the fitting smashing into it. So now the trans is out and it started to rain so I called it a night. But I will post pics as I go and hopefully I can help anyone who has any questions with this procedure. STC FITTING
Attached Thumbnails
Uncommon Problem?-imag0112.jpg   Uncommon Problem?-imag0113.jpg   Uncommon Problem?-imag0114.jpg   Uncommon Problem?-imag0115.jpg  
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-21-2012, 07:08 PM
War is the answer!


 

Join Date: Feb 2011
Location: Daytona Beach, Florida
Posts: 5,055
Thanks: 101
Thanked 64 Times in 19 Posts
Feedback Score: 2 reviews
Crap man sorry to hear this.
Reply With Quote Quick reply to this message
  #3  
Old 02-21-2012, 07:18 PM
Powerstroke.org Rookie
 

Join Date: Mar 2011
Location: Lombard IL
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks bud!!!! It is what it is I guess, but it could be worse. Im lucky enough to be able to fix this myself as aposed to taking it to the dealer. I work for beer so my time is basicaly free. Ive heard the STC fitting at the dealer is in the area of $3200 and the rear engine cover $2800. Dont quote me its 3rd party info.
Reply With Quote Quick reply to this message
  #4  
Old 02-26-2012, 10:45 AM
Compression Ignition Addict
 

Join Date: May 2010
Posts: 197
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Just a heads up.
Look in the old fitting for the circle clip and make sure it's all in there.
I have seen them blow out, get into the pan, get sucked up past the screen on the sump, and ruin the front cover and pump gears. It can take a day or a month to happen.
Reply With Quote Quick reply to this message
  #5  
Old 02-26-2012, 11:32 AM
Premium Member
 

Join Date: Jul 2011
Location: Monroe, Georgia
Posts: 3,863
Thanks: 1
Thanked 21 Times in 20 Posts
Feedback Score: 1 reviews
When possible, please post a pic of the cracked rear cover.
Reply With Quote Quick reply to this message
  #6  
Old 02-26-2012, 12:03 PM
Powerstroke Techie

 

Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,331
Thanks: 23
Thanked 83 Times in 74 Posts
Feedback Score: 4 reviews
ouch, that rear cover isn't cheap either. you're probably going to need a rear main seal and installer too
Reply With Quote Quick reply to this message
  #7  
Old 02-26-2012, 12:39 PM
Compression Ignition Addict
 

Join Date: Oct 2010
Location: Beautiful BC
Posts: 534
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Not terribly common, but it does happen!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
hard start, hpop low pressure, no start, oil leak, rear cover

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:33 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors