Temp Question - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-05-2012, 05:20 AM
Powerstroke.org Fanatic
 

Join Date: May 2011
Location: Stowe Pa.
Posts: 123
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Temp Question

Hi guys its been a little while on here but I like to see ifthis is normal. First a little back round, I have a 05 and already have done the coolent flush , EGR delete and oil cooler , along with a new t-stat back in November. The question is in Pa. the temp has droped outside to be in the 20,s and low 30,s . When Istart my truck withno trouble let itwarm up to about 125 deg and leave for work it seesm to take fore ever to get to 190deg then on my scan guage I see the stat open and drop to about to 186 deg and pretty much stays there unleesI realy push it then I MIGHT be able to get 190 deg out of it. Is this normal with my climate or do you think I might have a bad t-stat. I even put cardboard in front of my rad with no real noticable change. I might ad that I have had the truck since 06 and not have had this issue before, but I also had a real badly cloged oil cooler so I am thing that helped warm the motor up some.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-05-2012, 05:35 AM
Compression Ignition Addict

 

Join Date: Jun 2011
Location: Maine
Posts: 479
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine stays really cool in the winter without the winter front on. Even cardboard doesn't help that much. Unless I have my plow or winter front on my temps are usually around 184-186 unloaded. I replaced the T-stat too and didn't see any change at all.
Reply With Quote Quick reply to this message
  #3  
Old 01-05-2012, 06:29 AM
Powerstroke.org Fanatic
 

Join Date: May 2011
Location: Stowe Pa.
Posts: 123
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
thanks novemberdelta that is what I kinda figured, was just kindanot sure sincethis is the first winter since my upgrade's and clean system. It just runs better when the temp is above the 190 mark. Thanks again for the reply
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:27 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors