P2290 but truck runs perfect. - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 7 Old 01-03-2012, 01:16 PM Thread Starter
Compression Ignition Addict
 
Join Date: Dec 2010
Location: Buffalo NY
Posts: 363
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
P2290 but truck runs perfect.

P2290 Default inferred ICP is used, ICP is below desired pressure. Pulled code today. Every day or so I check with my insight. I just like to know whats going on. There was no CEL. Truck runs absolutely perfect, hot or cold. It was 11*f today. I cleared it and it has not returned. its an 04, Swash plate pump. Should I worry? Btw its on Vivians street tune.


03 F250 CC/SB 4x4
225k Miles
Dual Exhaust
All Else Stock
renegadedooer is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 01-11-2012, 06:26 PM Thread Starter
Compression Ignition Addict
 
Join Date: Dec 2010
Location: Buffalo NY
Posts: 363
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have on 2 occasions noticed a p2290 code with no CEL. I randomly check my edge insight for codes. Then today I got a CEL with a p2290. My truck runs perfect all the time, hot, cold, always runs perfect. My ICP voltages are all ok. Do your tunes effect ICP actual vs ICP desired? I read that the diablo tuner can cause a p2290. Just wondering if the tune could cause such a thing or if I have an HPOP leak. I had changed the #4 injector in Sept. When I did it I unbolted the wavy rail, leaving the stand pipe in the rail and pulled it out as one unit. I installed it the same way. Should I start by replacing the dummy plugs and stand pipes?


03 F250 CC/SB 4x4
225k Miles
Dual Exhaust
All Else Stock
renegadedooer is offline  
post #3 of 7 Old 01-12-2012, 09:26 AM Thread Starter
Compression Ignition Addict
 
Join Date: Dec 2010
Location: Buffalo NY
Posts: 363
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
at hot idle I have always had .8v ICP and at high Idle hot only had 1.0-1.1 v. I guess at high idle my ICP is supposed to be 1.8v. When the motor is cold my voltages are spot on but as it warms the pressure drops off a bit. I think I have a small HPO leak. I got updated dummy plugs and stand pipes today. I will change them out and check all my injector O rings while I am in there. I will let your guys know if it works out.


03 F250 CC/SB 4x4
225k Miles
Dual Exhaust
All Else Stock
renegadedooer is offline  
post #4 of 7 Old 01-12-2012, 09:41 AM
Compression Ignition Addict
 
DoubleDpsd's Avatar
 
Join Date: Mar 2007
Posts: 4,579
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 1 Time in 1 Post
Feedback Score: 1 reviews
subscribed. the sensor seems to be doing its job correct considering it relayed the low voltage readings to you?

2003 centennial edition f250 4x4 ccsb auto w/blackwater long block w/arp's, 4" exhaust, airaid intake, ODawg's manifold, itp's reg return, sap modified solenoid, DC power 185amp alt, motorcraft 850cca, Warn Hubs, RS 55w 6k hid's, harley headlights, bpd 58v 6 phase, bpd water pump, dieselsite coolant filter, elc coolant, php gryphon, Xcal2 w/unlimited tow, new hfcm, glowshift fuel psi gauge, icon level kit, 20" kmc hoss, 305/55 terra grapplers TOTALED
DoubleDpsd is offline  
post #5 of 7 Old 01-12-2012, 11:52 AM
Premium Member
 
Term3's Avatar
 
Join Date: Feb 2011
Location: Edmonton, Alberta Canada
Posts: 3,957
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 34 Times in 32 Posts
Feedback Score: 1 reviews
My '05 Ex which has the '04 engine will give me that code if I do some HIGH speed high boost cruising even though my gauge showed the pressure was fine.

SCT, no studs...yet, Dual OEM intake air filter housings, Banks intercooler & intake elbow, Banks exhaust system, Windrunner ported intake manifold, Bullet Proof Diesel remote oil cooler & thermostat, AirDog2 (plus a couple spares), Power steering filter (Amsoil dual-bypass), MagTec deep ATF pan, Electric oil pre-lub pump, Dakota Digital gauges.
Term3 is offline  
post #6 of 7 Old 01-12-2012, 03:52 PM
Compression Ignition Addict
 
amdriven2liv's Avatar
 
Join Date: Dec 2009
Location: Vancouver
Posts: 3,331
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 5
Thanked 47 Times in 42 Posts
Feedback Score: 0 reviews
Operating values for ICP. Motor hot, high idle is 2500 RPM.

KOEO Low Idle Hi Idle Operating Range

ICP KO=0.2 LI=1.0 HI=1.8 OR=.15-4.7 Volts Injection Control Pressure


ICP_DES KO=0 LI=625.5 HI=1400-1450 OR=0-4045 PRESSURE (PSI) ICP Desired

My Low Idle runs 585 psi


I don't recall my ICP volts.
amdriven2liv is offline  
post #7 of 7 Old 01-12-2012, 07:10 PM Thread Starter
Compression Ignition Addict
 
Join Date: Dec 2010
Location: Buffalo NY
Posts: 363
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I swapped out the drivers side dummy plugs and stand pipes. I got .2v increase on my Edge. I guess thats a step in the right direction. Will do the passenger side tomorrow.


03 F250 CC/SB 4x4
225k Miles
Dual Exhaust
All Else Stock
renegadedooer is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome