Power Loss & White Smoke - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-03-2012, 06:22 AM
Powerstroke.org Fanatic
 

Join Date: Oct 2007
Location: Cleveland
Posts: 113
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Power Loss & White Smoke

I recently have been starting my truck and having excessive white smoke for an extended period of time. Went to jump on highway one day and lost power, wouldn't shift, and white smoke. Got on side street and made it home, and it would shift but had to baby the accelerator. Then it wouldn't start.

Had it worked on it over Christmas with a buddy only to find that it had only 3/4 full oil after I just did an oil change and have never had issues before. Along with this, the FICM needed replaced. Now it runs great and no white smoke.

My question is where did my oil go? Would all the white smoke be the oil burning? I just don't want something to happen again and especially low oil. This is my first diesel, going on 4 years with minimum issues and so far everything that I can figure out. When it comes to this stuff, it is new to me.

Any input is appreciated. Thanks!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-03-2012, 06:47 AM
Compression Ignition Addict

 

Join Date: Jun 2011
Location: Maine
Posts: 479
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Burning oil would be blue. A lot of white smoke sounds like an EGR issue. Do a search on here you'll find all the info you need. Also check your degas bottle to make sure there isn't oil in it.
Reply With Quote Quick reply to this message
  #3  
Old 01-03-2012, 12:23 PM
Powerstroke.org Fanatic
 

Join Date: Oct 2007
Location: Cleveland
Posts: 113
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by novemberdelta View Post
Burning oil would be blue. A lot of white smoke sounds like an EGR issue. Do a search on here you'll find all the info you need. Also check your degas bottle to make sure there isn't oil in it.
Thanks! I thought EGR too, but the smoke has gone away after replacing FICM. I am just wondering where the 1/4 emptied oil went?!?!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:09 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors