Turbo - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-01-2012, 01:28 PM
Member
 

Join Date: Dec 2009
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turbo

I took my turbo out and replaced the unison ring. Now all back together won't build boost or anything like that. A friend thinks it is the oil line clogged? Any help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-01-2012, 01:35 PM
Powerstroke Techie

 

Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,324
Thanks: 23
Thanked 83 Times in 74 Posts
Feedback Score: 4 reviews
either it's still stuck or possibly your VGT solenoid isn't working. Did you clean the turbo while you had it all apart?

did you plug in the solenoid? any exhaust leaks? can you spin the impeller by hand?
Reply With Quote Quick reply to this message
  #3  
Old 01-01-2012, 02:28 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Posts: 390
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by sinner6.0L View Post
either it's still stuck or possibly your VGT solenoid isn't working. Did you clean the turbo while you had it all apart?

did you plug in the solenoid? any exhaust leaks? can you spin the impeller by hand?
Agreed. If you didn't seat the up pipe flange correctly on the turbine it will be extremely laggy.
Reply With Quote Quick reply to this message
  #4  
Old 01-01-2012, 03:37 PM
Member
 

Join Date: Dec 2009
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yea I cleaned all the veins and both housings. I'll check the both mainfoldd tomorrow
Reply With Quote Quick reply to this message
  #5  
Old 01-02-2012, 04:29 PM
Member
 

Join Date: Dec 2009
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I did both exhaust clamps over and seemed to be better but now the truck sputters still it seems like it struggles to get about 2000 rpm. It also kinda shakes when it won't rev up
Reply With Quote Quick reply to this message
  #6  
Old 01-02-2012, 04:29 PM
Member
 

Join Date: Dec 2009
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
To get above 2000rpm
Reply With Quote Quick reply to this message
  #7  
Old 01-02-2012, 05:04 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Posts: 390
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Did you plug in the MAF?
Reply With Quote Quick reply to this message
  #8  
Old 01-02-2012, 05:14 PM
Member
 

Join Date: Dec 2009
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Everything is plugged in all hoses are connected that I can see
Reply With Quote Quick reply to this message
  #9  
Old 01-02-2012, 08:01 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Posts: 390
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
How much PSI are you getting out of the turbo at WOT?
Reply With Quote Quick reply to this message
  #10  
Old 01-03-2012, 03:04 AM
Member
 

Join Date: Dec 2009
Posts: 42
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
About 30psi
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:49 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors