Those of you who had Edge CS that shuts off on it's own??? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-01-2012, 08:59 AM
Compression Ignition Addict
 

Join Date: Aug 2009
Location: South Hill, Wa
Posts: 387
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Those of you who had Edge CS that shuts off on it's own???

Anyone get a replacement from Edge that started doing the same thing?

My Insight CS has started doing the dreaded shut off on it's own. Probably about 10 times now in the last 2 months. It always starts back up though.

I am skeptical about sending it in for a replacement.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-01-2012, 09:04 AM
Member
 

Join Date: Oct 2010
Location: York, PA
Posts: 81
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine was doing it pretty regularly about a year ago. I sent it in & they repaired, not replaced, it. Super fast service & really helpful. In the past 2 months, it's done it twice so I'm not sure what's up. I have not chosen to send it back this time around . . . .yet.

-Hemicbx
Reply With Quote Quick reply to this message
  #3  
Old 01-01-2012, 09:11 AM
Premium Member
 

Join Date: Aug 2009
Location: Somewhere Between Good and Bad
Posts: 1,501
Thanks: 4
Thanked 22 Times in 22 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Mr. Black View Post
Anyone get a replacement from Edge that started doing the same thing?

My Insight CS has started doing the dreaded shut off on it's own. Probably about 10 times now in the last 2 months. It always starts back up though.

I am skeptical about sending it in for a replacement.
It cant hurt to ask for one. EDGE has great customer support.

My CTS was randomly shutting down a lot mid last year. I sent it back to EDGE and they found no problem. Re-installed it and the shutdowns continued. Called EDGE back and requested a replacement CTS. EDGE sent another CTS and I returned the original to them. Random shutdowns continued until the firmware update which included the mileage coach (forgot the number of the firmware). Ever since the CTS has been much more stable and I now get only 1 or 2 random shutdowns per month.

P.S. - I also changed out the cable connecting the CTS to the OBDII port during the troubleshooting process. Made no difference.
Reply With Quote Quick reply to this message
  #4  
Old 01-01-2012, 12:19 PM
Compression Ignition Addict
 

Join Date: Oct 2010
Posts: 327
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine has done it a couple times before but it hasnt done it in a while. I would have to unplug it and plug it back in and it would work fine.
Reply With Quote Quick reply to this message
  #5  
Old 01-01-2012, 12:28 PM
Compression Ignition Addict
 

Join Date: Aug 2009
Location: South Hill, Wa
Posts: 387
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I know this is a fairly common problem.

I must admit, I have not done any updates or firmware updates. I just took it out of the box and plugged it in.

Really though, those of you that have had this problem, have you ever fixed it by just doing a firmware update? My understanding is that it is a hardware failure.

I just want to know if I am gonna be wasting my time sending it in if my replacement is going to do the same damn thing?
Reply With Quote Quick reply to this message
  #6  
Old 01-22-2012, 02:57 PM
Compression Ignition Addict
 

Join Date: Aug 2009
Location: South Hill, Wa
Posts: 387
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Update, after talking to Edge, I took it out of the truck and created the Edge Fusion account.

Updated the firmware to the latest on their website. Problem seems to be gone. Hasn't shut off on it's own since even on hour long drives.

Will inform if the unit fails again.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:38 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors