Low Boost after work done - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-15-2011, 06:36 AM
Powerstroke.org Rookie
 

Join Date: Sep 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Low Boost after work done

I have a 2005 Excursion and I just had the motor pulled for HG, studs, EGR delete (bullet Proof Diesel) and oil cooler replacement, and many other replacements/upgrades. I had the turbo replaced with the Garrett Turbo for Ford 6.0L Power Stroke Diesel, GT3788VA, Stage 1, Non-Ball Bearing.

Once everything was put back together the turbo does not spook correctly and will only boos to about 15lbs. The truck fails/aborts on the self test. My mechanic has checked the y-pipe for leaks and we have replaced the VGT solenoid pigtail.

The truck is throwing the following codes. PO1000, PO407 and PO488.

I called my local Ford dealer to inquire about a diagnostic with them. They cannot look at it until after first of the year.

The truck runs great other than the low boost situation. I am about to pull my hair out over this one. Help and recommendations graciously accepted.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-15-2011, 07:04 AM
Compression Ignition Addict
 

Join Date: Sep 2011
Location: Flowood, Mississippi
Posts: 205
Thanks: 7
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by stainman View Post
I have a 2005 Excursion and I just had the motor pulled for HG, studs, EGR delete (bullet Proof Diesel) and oil cooler replacement, and many other replacements/upgrades. I had the turbo replaced with the Garrett Turbo for Ford 6.0L Power Stroke Diesel, GT3788VA, Stage 1, Non-Ball Bearing.

Once everything was put back together the turbo does not spook correctly and will only boos to about 15lbs. The truck fails/aborts on the self test. My mechanic has checked the y-pipe for leaks and we have replaced the VGT solenoid pigtail.

The truck is throwing the following codes. PO1000, PO407 and PO488.

I called my local Ford dealer to inquire about a diagnostic with them. They cannot look at it until after first of the year.

The truck runs great other than the low boost situation. I am about to pull my hair out over this one. Help and recommendations graciously accepted.
I know your mechanic might have told you there were no leaks, but have you checked yourself? If not, check the connection at the EGR/Delete and make sure it does not sound like a vacuum/hiss.
Reply With Quote Quick reply to this message
  #3  
Old 12-15-2011, 08:09 AM
Compression Ignition Addict
 

Join Date: Oct 2010
Location: Chestertown Md
Posts: 301
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
What he said.
Reply With Quote Quick reply to this message
  #4  
Old 12-15-2011, 07:48 PM
Compression Ignition Addict
 

Join Date: Aug 2008
Location: Citrus County, FL
Posts: 446
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Send a message via AIM to Stroked7.3
Also Check to make sure your turbo boot isnt damaged or cracked, its a common problem on these trucks. Like everyone else said start it up and listen for a high pitch hissing sound
Reply With Quote Quick reply to this message
  #5  
Old 12-15-2011, 09:16 PM
Powerstroke Techie

 

Join Date: Aug 2010
Location: Sassamansville, Pa
Posts: 9,669
Thanks: 86
Thanked 184 Times in 148 Posts
Feedback Score: 3 reviews
Also don't forget to check the MAP hose, look for holes or cracks, you can even pull the hose off and clean it out along with making sure the fitting at the intake manifold isn't blocked up with carbon.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:11 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors