HELP! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-27-2011, 02:41 PM
Compression Ignition Addict
 

Join Date: Aug 2010
Location: North Charleston, Sc
Posts: 191
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HELP!

Ok, so 2 months ago i head the egr deleted, oil cooler replaced, a new stat put in, and arps installed.. Just this past week i had an injector replaced, ICP sensor replaced, and glow plug harness replaced.. After getting the egr done, oil cooler, and all that stuff the truck ran brilliantly for 2 weeks or so then starting acting up.. Hard to crank in the morning (takes 3 or 4 trys before it fires up and shoots out thick black smoke each attempt), and terrible gas mileage. Just this past week the CEL came on and diagnostics test revealed injector 7 was low, icp sensor was bad, and glow plug 6 was bad.. I figured the injector was the problem and got it back from the shop from yesterday and its still doing it! What else could it be?!!? FICM checked out at 48v! Im out of ideas and getting frustrated after dumping well over 4 grand into over the past 2 months.. Before i had did the preventative maintenence stuff and had the egr deleleted, new oil cooler installed, and arps's put in it wasnt giving me any problems..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-27-2011, 02:49 PM
Compression Ignition Addict
 

Join Date: Mar 2011
Posts: 317
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
yikes man...good luck, hopefully someone who knows will chime in. Does it start fine once its warm??
Reply With Quote Quick reply to this message
  #3  
Old 08-27-2011, 02:52 PM
Compression Ignition Addict
 

Join Date: Aug 2010
Location: North Charleston, Sc
Posts: 191
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by californiadreamin View Post
yikes man...good luck, hopefully someone who knows will chime in. Does it start fine once its warm??
Yea, after the initial crank for the day it fires right up... Its just the morning crank giving me crap, but my gas mileage has went down from about 15/16 to 10ish..
Reply With Quote Quick reply to this message
  #4  
Old 08-27-2011, 03:05 PM
Compression Ignition Addict
 

Join Date: Jul 2011
Location: Houston, TX
Posts: 264
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
When did you check the FICM Voltage? While it was running? While it was sitting? While it was cranking?

Have you checked your fuel pressure? Both while running and while starting. Too low will cause starting problems and damage injectors.

Try Rev-X in your oil. Hopefully it'll help your injectors some if theyre sticking or having other problems.
Reply With Quote Quick reply to this message
  #5  
Old 08-27-2011, 03:10 PM
Compression Ignition Addict
 

Join Date: Aug 2010
Location: North Charleston, Sc
Posts: 191
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Dicion View Post
When did you check the FICM Voltage? While it was running? While it was sitting? While it was cranking?

Have you checked your fuel pressure? Both while running and while starting. Too low will cause starting problems and damage injectors.

Try Rev-X in your oil. Hopefully it'll help your injectors some if theyre sticking or having other problems.
FICM was checked when it was at the shop getting the injector replaced, and ICP sensor replaced.. It was checking while cranking and running and was 48 volts across the board..

I have not checked fuel pressure.. How do i check that? I know it needs to about 60psi or so correct? But how can i check while running and cranking to ensure I am getting enough fuel? My pump itself is new, about 8 months old, but i dont think i have the updated blue spring...
Reply With Quote Quick reply to this message
  #6  
Old 08-28-2011, 07:42 AM
Compression Ignition Addict
 

Join Date: May 2011
Location: Rocklin, CA (Sacramento Area)
Posts: 826
Thanks: 2
Thanked 16 Times in 14 Posts
Feedback Score: 3 reviews
When was the last fuel filter done?

Also it sounds like maybe you batteries might be weak? When was the last time they were checked or replaced?

Todd
Reply With Quote Quick reply to this message
  #7  
Old 08-28-2011, 02:59 PM
Compression Ignition Addict
 

Join Date: Aug 2010
Location: North Charleston, Sc
Posts: 191
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by white59rt View Post
When was the last fuel filter done?

Also it sounds like maybe you batteries might be weak? When was the last time they were checked or replaced?

Todd
Fuel filters havent been too long, maybe 5k miles tops.. Both batteries and the alternator were replaced in March.. They should be good.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:26 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors