what happened ? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 08-23-2011, 04:36 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: May 2011
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
what happened ?

Just went to pickup my truck from the dealer who did head gaskets, egr cooler and oil cooler. I make it about a 1/4 mile up the road and im cruising along at about 30 mph and the rpms start to go crazy and Im watching white/blue smoke pour out of the exhaust. I pull onto the next street and turn around and the truck just didn't want to move at all. Was lugging and just left a cloud of white/blue smoke everywhere. So I limp back to the dealer and that was that. Any idea what they're going to say ? Thankfully this is under warranty, but I wanted my truck back . Just a note, when I started the truck up for the first time I didn't really hear the turbo at all in my exhaust like I normally do.
Ronisonce is offline  
post #2 of 6 Old 08-23-2011, 04:42 PM
Compression Ignition Addict
 
Join Date: Jan 2007
Location: Williamsburg, Ohio
Posts: 1,049
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I guess they were too busy for a test drive. Hope they make it good.

2004 F-250, ZF-6, 03 turbo 4" mbrp exh. PHP reprogrammed FICM, sct X3, egr delete, auto meter ultra lite boost & pyro, arp head studs, firestone destination m/t's. ccv mod, mag hytec diff covers, 35% tint, dieselsite coolant filter, cat elc, B&W gooseneck hitch.
screamin7.3 is offline  
post #3 of 6 Old 08-23-2011, 04:54 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: May 2011
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
The funny thing is that when I picked up the truck they had just gotten back from taking it for a 40 mile run. I'm a bit disappointed.
Ronisonce is offline  
post #4 of 6 Old 08-23-2011, 05:56 PM
Long Member
 
TMAG6.0's Avatar
 
Join Date: Jun 2009
Location: SE Houston
Posts: 404
Thanks: 6
Thanked 12 Times in 12 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
You always look at the last thing you did....they F-ed something up

2014 6.7 CCSB FX4
Edge CTS
6" RCX Lift
H&S Turbo Kit
DieselSite Filters
S&B Intake - Dry
No Limit EGR Delete
4" Flo-Pro / Donaldson
H&S Tunes via XRT Pro
Bilstein 5160s Front 5125s Rear
60gal RDS Auxiliary Fuel Tank/Toolbox

Click HERE to save a childs life.

TMAG6.0 is offline  
post #5 of 6 Old 08-24-2011, 03:09 PM Thread Starter
Powerstroke.org Fanatic
 
Join Date: May 2011
Posts: 146
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
Evidently it was the Exhaust Pressure Sensor ? I guess it was a wonderful coincidence for that to go as soon as I took the truck. Lucky me.
Ronisonce is offline  
post #6 of 6 Old 08-24-2011, 03:20 PM
Powerstroke Techie

 
Join Date: Nov 2010
Location: South Fayette/Pittsburgh PA
Posts: 5,825
Thanks: 33
Thanked 143 Times in 129 Posts
Mentioned: 0 Post(s)
Quoted: 13 Post(s)
Garage
Feedback Score: 4 reviews
haha nevermind

-Matt

Ford Senior Master Tech

2015 F-250 XLT 6.7L

2006 F-250 6.0L SOLD
sinner6.0L is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome