04...1/2? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-21-2011, 10:10 AM
Compression Ignition Addict
 

Join Date: Aug 2009
Posts: 362
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
04...1/2?

I just bought a 04 f350, so I figured I'd try my buddies 03/04 edge on it. I tried it on my 05 but it just lit up the screen but didn't display anything so I figured out it was for the 03/04. As I was installing it the screen lit up and everything but no smoke or extra power, then I found my Rottweiler eating the monitor so I took it back off, as I wa taking it off I noticed my icp in the valve cover, making it a 04.5?
What's different between the 04.5 and the 05-07? I noticed my intake horn is different and has some kind of valve on it but other then that what's different?and to order parts would I have to get 05-07 parts?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-21-2011, 12:24 PM
Powerstroke Techie

 

Join Date: Aug 2010
Location: Sassamansville, Pa
Posts: 9,732
Thanks: 93
Thanked 189 Times in 152 Posts
Feedback Score: 3 reviews
You can find some of the running changes here.
http://www.forddoctorsdts.com/articl...icle-06-08.php
Reply With Quote Quick reply to this message
  #3  
Old 08-21-2011, 01:12 PM
Compression Ignition Addict
 

Join Date: Feb 2011
Location: upstate ny
Posts: 2,254
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 7 reviews
What model is the attitude/monitor? The later ones worked for all 6.0's, some of the older ones were year specific.
Reply With Quote Quick reply to this message
  #4  
Old 08-21-2011, 06:49 PM
Compression Ignition Addict
 

Join Date: Aug 2009
Posts: 362
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks!!
And the edge I'm not sure about, the levels went up and down but I never felt a power gain or saw any smoke..
Later today I tried installing a superchip on it and it started reading my stock program and the programmer just shut off and wouldn't come back on.. Just not meant to be I guess lol..thought it was the obd2 but my scanner worked just fine
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:21 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors