Fixed the truck, but somethings not right - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-27-2011, 06:32 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2010
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fixed the truck, but somethings not right

Get a cold one, this one could be a long one.

First a refresher. I have a 2005 F350 XLT 4x4 Dually. I couldn't get anything better than 7 or 8 MPG. Truck was tossing the wrench light when towing, especially uphill and when it was really hot out. Dealer was useless, said the truck was fine. I said BS. The wrench light never set a code, so never knew what was causing that. I've been living with this for about a year. Diesel prices hit over $4.50 and I said I had to do something. I wasn't giving up camping that easily.
I decided to start throwing parts at it.

Yanked the air filter (found out it was the original one, 95,000 miles on it).
Yanked the muffler and replaced it with a Walker BTM.

Guess what. Pulling 7500 pounds of trailer and the mileage is up to 11 MPG. These are all hand calculated MPG's.

Just got back from 2 camping trips and no wrench lights either.

You may ask what could still be wrong. Well, it feels strange. Like it's congested. Like it has a head cold. I checked the air filter, it's in correctly.

I can hear the turbo exercising itself when I first start the truck up. Couldn't do that with the stock muffler.

I don't know what it could be. Did the truck lose power with the muffler replacement?

I also noticed that with the new air filter and muffler the truck isn't down shifting on hills as much as it did. The boost goes up to 20 or a bit more, the speed will hold or drop a bit but there is no downshift unless it's a really big or long hill. Seems like the truck is boosting more and downshifting less.

Here's a fix that I can't believe but it seems to have done something. I noticed that my third brake light was out. At the same time I read in an RV forum that if it's out the transmission will not shift correctly and you may have cruise control problems. Anyone ever hear of this one? My tow haul mode is working better and the cruise is holding better after replacing the third brake light bulb.

Any ideas? I'm happy with 11 MPG but a bit concerned if I'm losing power with the new muffler. Maybe the cats plugged?

Thanks for reading

Fred
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-27-2011, 06:51 PM
Compression Ignition Addict
 

Join Date: Jun 2010
Location: Northern Illinois
Posts: 378
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Are you against deleting the cat and muffler altogether? It will boost MPG and power...can't hurt.
Reply With Quote Quick reply to this message
  #3  
Old 06-27-2011, 06:51 PM
Compression Ignition Addict
 

Join Date: Dec 2010
Posts: 1,191
Thanks: 10
Thanked 28 Times in 26 Posts
Feedback Score: 0 reviews
have you cleaned the EGR valve?, cleaned the turbo? Just as a FYI I have a all stock except no cat exhaust 4" downpipe to 5", early style 05 w/MAF CCLB and I pull 14.25MPG city and 17.5mpg hwy. BTW that mpg is not towing.
Reply With Quote Quick reply to this message
  #4  
Old 06-27-2011, 06:58 PM
Slacker



 

Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 17,181
Thanks: 13
Thanked 56 Times in 44 Posts
Feedback Score: 4 reviews
Really? The third brake light affects tranny shifting? Not likely. Those wacky Ford engineers wouldn't stoop to that level to screw with us, would they?

I would start with the EGR valve cleaning and go from there.
Reply With Quote Quick reply to this message
  #5  
Old 06-27-2011, 06:59 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 599
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I would def. check EGR and Turbo and heck get rid of that cat. . But i've never heard of a third brake light causing a shifting cruise control problem., and no deleting your muffler/changing air filter won't cause u to lack power. Did you happen to make sure your MAF (Mass air flow) sensor was clean or did you get a little debris on it when you changed it. If you suspect you did get some MAF cleaner from your local auto part store spray some on the sensor. Be careful when you do this they are extremely sensitive. Then just let air dry for a few minutes. Put it back on and see what she does.
Reply With Quote Quick reply to this message
  #6  
Old 06-27-2011, 07:06 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 599
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Also i do know on the Ford gas cars, air filters can cause a wrench light if they are not properly seated
Reply With Quote Quick reply to this message
  #7  
Old 06-27-2011, 07:11 PM
Premium Member
 

Join Date: Jan 2011
Location: Sugar Land/Missouri City, Texas
Posts: 602
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews

....
Reply With Quote Quick reply to this message
  #8  
Old 06-27-2011, 07:40 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2010
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by rem1981 View Post
Are you against deleting the cat and muffler altogether? It will boost MPG and power...can't hurt.
The Ohio EPA is making me keep the cat, don't need the yearly emissions check but they told me that they will do random checks sometime in the future. Muffler I need for the Ford warranty. Ford dealer just sent a service reminder with a note that if any aftermarket parts cause any issues your warranty will be voided. How nice of them.
Reply With Quote Quick reply to this message
  #9  
Old 06-27-2011, 07:42 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2010
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by U235a4 View Post
have you cleaned the EGR valve?, cleaned the turbo? Just as a FYI I have a all stock except no cat exhaust 4" downpipe to 5", early style 05 w/MAF CCLB and I pull 14.25MPG city and 17.5mpg hwy. BTW that mpg is not towing.
Did an EGR cleaning a year ago, guess it wouldn't hurt to try that again. Haven't thought about a turbo cleaning, read a lot about them, don't know if I'm ready to tackle it.
Reply With Quote Quick reply to this message
  #10  
Old 06-27-2011, 07:44 PM
Powerstroke.org Fanatic
 

Join Date: Jul 2010
Posts: 109
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by thenubsterman View Post
I would def. check EGR and Turbo and heck get rid of that cat. . But i've never heard of a third brake light causing a shifting cruise control problem., and no deleting your muffler/changing air filter won't cause u to lack power. Did you happen to make sure your MAF (Mass air flow) sensor was clean or did you get a little debris on it when you changed it. If you suspect you did get some MAF cleaner from your local auto part store spray some on the sensor. Be careful when you do this they are extremely sensitive. Then just let air dry for a few minutes. Put it back on and see what she does.
No MAF on my truck. There is something else like it but it's not a MAF. I can clean that too.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:42 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors