Help help help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-26-2011, 09:59 AM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Help help help

Driving home towing my boat yesterday with cruise on 70 when.....the truck misses and My Cts edge ficm voltage meter goes down to 34v.... I lost all power but was able to limp off the interstate....thing is...The volts on the ficm are now normal if I start the truck according to my cts...the truck has no power at all and can hardly get going to 20mph...it sounds friggin awful....I just put a swamps 58v ficm in my truck and have only put 400 miles on it.....there was and is no smoke coming out of my tailpipe so I don't think it is the injectors???? Really don't know...my engine is throwing all the ficm codes I was getting before I replaced my old original ficm...my ot and ct were at 196 and 192 when it happened....do you guys think it is my new ficm....I had to get my truck and boat towed 90 miles home aaa only covered my truck ....so I had to pay $3.30 a mile for my boat + a $65 hook up fee.....not a happy camper....The whole reason I got the new ficm was so this would not happen to me!!! The old one still worked fine once the truck warmed up.....
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-26-2011, 10:35 AM
Emergency Services

 

Join Date: Apr 2011
Location: Geraldton
Posts: 742
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I would probably put the old FICM back on (if you still have it) and see how it runs. If the problem goes away you have your answer, if not keep looking.

I see that NYC is looking at this, he'll probably have a better answer than me!
Reply With Quote Quick reply to this message
  #3  
Old 06-26-2011, 03:12 PM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Old one was sent in for the $350 core charge.......
Reply With Quote Quick reply to this message
  #4  
Old 06-26-2011, 03:54 PM
information regurgitator
 

Join Date: Dec 2010
Location: Epping, NH
Posts: 5,956
Thanks: 21
Thanked 187 Times in 174 Posts
Feedback Score: 0 reviews
Check all the plugs that plug into the FICM. They can be a real bear at times to get fully seated and locked in. Having a Swamps FICM go bad is an EXTREMELY rare event.
If the plugs are fully set, check the black ground wire that is on the bracket. Make sure that is in one piece.

Failing those, call Swamps tomorrow morning.
Reply With Quote Quick reply to this message
  #5  
Old 06-27-2011, 08:53 AM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Checked everything.....unplugged everything and plugged back in....nada....called swamps and they are sending me another to see if that indeed is the problem....I am getting the ficm codes on my edge cts...I have cleared them and they keep coming back....soooo...I suspect it is the ficm....by the way Dave at swamps was awesome....after all the stuff I have been reading regarding other shops and problems with customer service I feel compelled to give swamps a giant thumbs up....although if it is the ficm I am out a couple hundred for the tow home because of it's failure.....
Reply With Quote Quick reply to this message
  #6  
Old 06-27-2011, 10:16 AM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Anyone else have any ideas what it could be?? When I start it has a hard time even idleing and it sounds like only half of my engine is running....
Reply With Quote Quick reply to this message
  #7  
Old 06-27-2011, 06:53 PM
Compression Ignition Addict
 

Join Date: Dec 2007
Posts: 599
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well, did you try the ficm yet, and remember it is still mechanical parts they all fail. So ya it is a bummer that your out the few hundred dollars. It is probably the ficm, sense the ficm runs all of your injectors, if the ficm ends up being okiay, check the EGR valve. but i have a feeling its a ficm issue with ficm codes present
Reply With Quote Quick reply to this message
  #8  
Old 06-27-2011, 08:20 PM
Compression Ignition Addict
 

Join Date: Oct 2009
Location: Robinson Twp PA (Pittsburgh)
Posts: 4,515
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Send a message via AIM to Galaxie
Sounds like you are right FICM. Subscribing to see if your new one will fix. Hope it does bro!
Reply With Quote Quick reply to this message
  #9  
Old 07-01-2011, 12:55 PM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well put the new ficm in and now the truck won't even start.....I am at a loss....I have no idea what is wrong with my truck.....fuel pump? Anyone else have any idea what could be wrong?
Reply With Quote Quick reply to this message
  #10  
Old 07-01-2011, 01:52 PM
Powerstroke.org Rookie
 

Join Date: Mar 2010
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The new ficm they sent me was a 48v.....I took it out and put the 58v back in and the truck starts.....still has no power and is throwing codes p0264 p0267 p0273 p0282 p1000
P2614
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:30 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors