Edge Insight EGT Probe Issue - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 06-18-2011, 01:54 PM Thread Starter
Compression Ignition Addict
 
Join Date: Sep 2007
Posts: 888
Thanks: 16
Thanked 21 Times in 20 Posts
Mentioned: 2 Post(s)
Quoted: 40 Post(s)
Feedback Score: 0 reviews
Edge Insight EGT Probe Issue

I've had an Edge Insight for about 2 years now....and LOVE IT! Few weeks ago, I purchased and installed the EGT probe....and on a trip just last weekend, it worked well. Got home Sunday, parked the truck and today when I got back in the truck, the Edge Insight wouldn't power up.

Checked the OBDII fuse...all fine (and cigar lighter worked too). Unplugged and replugged back in the Edge Insight....nothing. So, I unplugged the EGT probe wire and poof....it comes back on. Plug it back it, and it goes off.

So now I'm wondering....what is wrong? Can a probe go bad? Or is it my Insight that just doesn't like it anymore? I have checked and all the cabling is fine....no rubbed wires, etc.

Thoughts?
jd4010 is offline  
post #2 of 11 Old 06-18-2011, 03:57 PM
Compression Ignition Addict
 
Join Date: May 2010
Location: Warren, Oregon
Posts: 1,515
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Sounds like the pyro looks like a call to edge.
2 stroker

06 F350 4x4 PSD Lariat FX4 CC LB
Edge Insight CTS Expandable Pyro
AutoMeter Fuel Pressure Gauge
Updated Fuel Reg. Kit 3C3Z-9T517-AG
Amsoil By-Pass(Amsoil 5w40)
Delo ELC Coolant
Coolant Filtration System
pulling a 14,000 lb Alpenlite 5er
97 F350 4x4 PSD CC LB
PacBrake&ATS converter lockup
3" dp 4" exhaust
TruCool 28,000 lb cooler
Tymar Intake
A piller EGT,Boost,Trans
2 stroker is offline  
post #3 of 11 Old 06-20-2011, 06:11 AM
Slacker



 
Evil Eye's Avatar
 
Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 18,510
Thanks: 16
Thanked 222 Times in 193 Posts
Mentioned: 19 Post(s)
Quoted: 140 Post(s)
Feedback Score: 4 reviews
Mine was doing something similar, although mine is directly related to the heat of the CS. It's mounted on the windshield in the direct sunlight and it gets VERY hot so it turns itself off. I pointed my AC duct on it and it's been fine since. I would guess your issue is probably similar.

Shawn Carlson
EvilEye@powerstroke.org

Proud Navy Vet
2005 F250, CCSB, 6.0 PSD, FX4 (The Sweet Unit is white)
2008 F350, CCLB, 6.4 PSD (Brad-the wife's truck is black)




Engine Mods:
Fluidampr
CCV Reroute (Reinstated)
4" MBRP Exhaust
MTW Stage 1 Turbo
Bulletproof 53V FICM
BulletProof EGR Cooler
BulletProof Water Pump
Riff Raff Intercooler Boots
Gogo Diesel Direct Drive Solenoid
BulletProof All-Aluminum Radiator
BulletProof All-Aluminum Intercooler
BulletProof Oil Cooler System w/ Bypass Filter
SCT w/ Custom Tunes (TSD, DJ's, Innovative, Gearhead, QuickTricks)

Exterior Mods:
Bilstein 5100 Shocks
Icon Adjustable Trac Bar
Firestone RideRite Air Bags
BDS Dual Steering Stabilizer
Aluminum Finned Differential Cover
Reese 16k Manual Slider 5th Wheel Hitch
Icon 2.5" Leveling Kit w/ F-350 rear blocks
20" BMF Novakanes wrapped in 33" Nitto Terra Grapplers
Evil Eye is offline  
post #4 of 11 Old 06-20-2011, 07:34 PM
Premium Member
 
Join Date: Aug 2009
Location: Somewhere Between Good and Bad
Posts: 1,944
Thanks: 10
Thanked 61 Times in 60 Posts
Mentioned: 7 Post(s)
Quoted: 26 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by jd4010 View Post
I've had an Edge Insight for about 2 years now....and LOVE IT! Few weeks ago, I purchased and installed the EGT probe....and on a trip just last weekend, it worked well. Got home Sunday, parked the truck and today when I got back in the truck, the Edge Insight wouldn't power up.

Checked the OBDII fuse...all fine (and cigar lighter worked too). Unplugged and replugged back in the Edge Insight....nothing. So, I unplugged the EGT probe wire and poof....it comes back on. Plug it back it, and it goes off.

So now I'm wondering....what is wrong? Can a probe go bad? Or is it my Insight that just doesn't like it anymore? I have checked and all the cabling is fine....no rubbed wires, etc.

Thoughts?
Have you tried the recently released firmware update from EDGE? Prior to loading the update my CTS (with EAS and EGT probe) would randomly shutdown, and with no consistent pattern.

I originally sent the unit back to EDGE and they troubleshooted and found nothing. They returned it to me and the problem continued. I retuned the original unit for a second time and asked for a new unit. EDGE sent a new one, but the same periodic shutdowns continued until I recently loaded the firmware update. Since then no periodic shutdowns have occured (its been two weeks or so).

2006 CC SB 4x4 6.0L
KC Stage 1.5
BPD 6 Phase 53v FICM, EGR, HD Oil Cooler, Bypass Oil Filter & Water Pump
ARP Studs w/ OEM Gaskets
DC Power 190a upper; DB Electric 200a lower alternator
295/65/20 Toyo MTs
PMF 3 Link
7,500LB Tuff Trucks Leveling Coils
Icon 2.5 piggyback CDC shocks
Dynatrac Free Spin Kit with Dynaloc Hubs
EDGE CTS Monitor w/ EGT, pressure, and temp sensors
Blue FPR Spring Kit
Twin F450 Auxiliary Springs
Banks Monster Exhaust
Truetrac rear/E locker Front with 4.11s
skanj0 is offline  
post #5 of 11 Old 06-22-2011, 06:36 AM
Slacker



 
Evil Eye's Avatar
 
Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 18,510
Thanks: 16
Thanked 222 Times in 193 Posts
Mentioned: 19 Post(s)
Quoted: 140 Post(s)
Feedback Score: 4 reviews
Mine shut down on me twice over the past 2 days. Looks like when I press the enter button, it comes back online and stays online. I believe I have the newest firmware from about 2 weeks ago.

Shawn Carlson
EvilEye@powerstroke.org

Proud Navy Vet
2005 F250, CCSB, 6.0 PSD, FX4 (The Sweet Unit is white)
2008 F350, CCLB, 6.4 PSD (Brad-the wife's truck is black)




Engine Mods:
Fluidampr
CCV Reroute (Reinstated)
4" MBRP Exhaust
MTW Stage 1 Turbo
Bulletproof 53V FICM
BulletProof EGR Cooler
BulletProof Water Pump
Riff Raff Intercooler Boots
Gogo Diesel Direct Drive Solenoid
BulletProof All-Aluminum Radiator
BulletProof All-Aluminum Intercooler
BulletProof Oil Cooler System w/ Bypass Filter
SCT w/ Custom Tunes (TSD, DJ's, Innovative, Gearhead, QuickTricks)

Exterior Mods:
Bilstein 5100 Shocks
Icon Adjustable Trac Bar
Firestone RideRite Air Bags
BDS Dual Steering Stabilizer
Aluminum Finned Differential Cover
Reese 16k Manual Slider 5th Wheel Hitch
Icon 2.5" Leveling Kit w/ F-350 rear blocks
20" BMF Novakanes wrapped in 33" Nitto Terra Grapplers
Evil Eye is offline  
post #6 of 11 Old 06-22-2011, 07:19 AM Thread Starter
Compression Ignition Addict
 
Join Date: Sep 2007
Posts: 888
Thanks: 16
Thanked 21 Times in 20 Posts
Mentioned: 2 Post(s)
Quoted: 40 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by Evil Eye View Post
Mine shut down on me twice over the past 2 days. Looks like when I press the enter button, it comes back online and stays online. I believe I have the newest firmware from about 2 weeks ago.
I called Tech Support and worked with Edge....appears to be the EGT probe has gone bad. When removed from the manifold, it works fine. But as soon as it is installed (grounded), the Insight monitor won't come on.

Was VERY impressed with their tech support line! They are sending me a replacement probe at no charge provided I return the failed one within 30 days. Good to see that there are a few reputable companies left that stand behind their products.
jd4010 is offline  
post #7 of 11 Old 06-22-2011, 07:48 AM
Compression Ignition Addict
 
Galaxie's Avatar
 
Join Date: Oct 2009
Location: Robinson Twp PA (Pittsburgh)
Posts: 4,539
Thanks: 2
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to Galaxie
Good to hear they took care of you!

Colin
59-68Galaxies, Fairlanes
54 Ford Skyliner Glass Top
60 Country Sedan Wagon
87/93 5.0s 347
Buy/Sell/Trade/Service 40s50s60s cars!
06 F350 Dark Stone XLT FX4
SCTX3 Custom Tunes
ARP Head Studs
EGR Cooler gone
MBRP Stright Pipe
Edge Insight
20" Harleys 35" AT2
2011 Tailgate
Eaton TrueTrac
2" Leveling
Black Windows/lights
Blue Spring
03 Turbo
Galaxie is offline  
post #8 of 11 Old 06-22-2011, 02:21 PM
Slacker



 
Evil Eye's Avatar
 
Join Date: Dec 2006
Location: Surprise, Arizona
Posts: 18,510
Thanks: 16
Thanked 222 Times in 193 Posts
Mentioned: 19 Post(s)
Quoted: 140 Post(s)
Feedback Score: 4 reviews
Quote:
Originally Posted by jd4010 View Post
I called Tech Support and worked with Edge....appears to be the EGT probe has gone bad. When removed from the manifold, it works fine. But as soon as it is installed (grounded), the Insight monitor won't come on.

Was VERY impressed with their tech support line! They are sending me a replacement probe at no charge provided I return the failed one within 30 days. Good to see that there are a few reputable companies left that stand behind their products.
Glad to hear it. I wonder if my problem is similar, although just pressing the enter button (I have the CS) seems to bring it back to life.

Shawn Carlson
EvilEye@powerstroke.org

Proud Navy Vet
2005 F250, CCSB, 6.0 PSD, FX4 (The Sweet Unit is white)
2008 F350, CCLB, 6.4 PSD (Brad-the wife's truck is black)




Engine Mods:
Fluidampr
CCV Reroute (Reinstated)
4" MBRP Exhaust
MTW Stage 1 Turbo
Bulletproof 53V FICM
BulletProof EGR Cooler
BulletProof Water Pump
Riff Raff Intercooler Boots
Gogo Diesel Direct Drive Solenoid
BulletProof All-Aluminum Radiator
BulletProof All-Aluminum Intercooler
BulletProof Oil Cooler System w/ Bypass Filter
SCT w/ Custom Tunes (TSD, DJ's, Innovative, Gearhead, QuickTricks)

Exterior Mods:
Bilstein 5100 Shocks
Icon Adjustable Trac Bar
Firestone RideRite Air Bags
BDS Dual Steering Stabilizer
Aluminum Finned Differential Cover
Reese 16k Manual Slider 5th Wheel Hitch
Icon 2.5" Leveling Kit w/ F-350 rear blocks
20" BMF Novakanes wrapped in 33" Nitto Terra Grapplers
Evil Eye is offline  
post #9 of 11 Old 06-22-2011, 02:29 PM
Compression Ignition Addict
 
BIGBILL105 45's Avatar
 
Join Date: Oct 2008
Location: Batavia, Ohio
Posts: 2,597
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to BIGBILL105 45
Thread kinda had me worried as I'm about to install my egt probe for my CS probably this week.

PM ME FOR VINYL DECALS!
SOLD!!!!!

ARP head studs
4 inch down pipe
5 inch straight pipe
ts 6 pos chip
foil delete w/ polished IC pipes
ugly step delete
2% tint
black lariat rims
35 inch Pro Comp Xterrains
7 inch in dash dvd player
remote starter
16.265
BIGBILL105 45 is offline  
post #10 of 11 Old 06-22-2011, 02:47 PM
Compression Ignition Addict
 
dazdillenger's Avatar
 
Join Date: Feb 2011
Location: upstate ny
Posts: 2,254
Thanks: 0
Thanked 3 Times in 3 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 7 reviews
Edge has awesome customer service. Some of the best in the industry.



2005 Lariat CCSB F-350 SRW
300,000 miles and going strong

Exterior
12" fabtech lift with 40" Xterrain's on M/T classic locks, Adjustable track bar, Bilstein 7100 reservoir shocks

Performance
Edge juice/attitude CTS, SCT with ID tunes, Snow meth. injection, Diamond eye 4" exhaust, 03 turbo, ARP studs, Sinister coolant filter

Interior
2010 stone seats/console, pioneer avic d3 with backup camera/bluetooth

Misc.
Viair 450c compressor, dual 2.5 gallon tanks, air horns rated @115db
dazdillenger is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome