Insight CS Problem - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-25-2011, 04:44 PM
Compression Ignition Addict
 

Join Date: Oct 2010
Location: Chestertown Md
Posts: 301
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Insight CS Problem

Has anyone else had issues with their insight? I've had mine since Nov. and its been great up untill today. This afternoon I noticed it wasnt on at all. When I parked the truck I shut it down and checked the connections, still nothing. Earlier tonught I hooked it to the fusion software, it was recognized, updated, and it was on but I could barely see the screen. After it updated I took it back to the truck. The backlight around the buttons came on and still have not gone off. Any ideas or am I buying another?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-25-2011, 04:46 PM
Illiana Chapter Director

 

Join Date: Feb 2008
Location: Bloomington, IN.
Posts: 11,928
Thanks: 4
Thanked 48 Times in 45 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by Fox'sFord View Post
Has anyone else had issues with their insight? I've had mine since Nov. and its been great up untill today. This afternoon I noticed it wasnt on at all. When I parked the truck I shut it down and checked the connections, still nothing. Earlier tonught I hooked it to the fusion software, it was recognized, updated, and it was on but I could barely see the screen. After it updated I took it back to the truck. The backlight around the buttons came on and still have not gone off. Any ideas or am I buying another?
Shoud be under warranty.
Reply With Quote Quick reply to this message
  #3  
Old 05-25-2011, 04:50 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Maryland
Posts: 353
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sounds like the back light went out. at night take a flashlight when it should be on and point it close to the screen i bet its working but for some reason the back light stopped working.
Reply With Quote Quick reply to this message
  #4  
Old 05-25-2011, 04:57 PM
Compression Ignition Addict
 

Join Date: Oct 2010
Location: Chestertown Md
Posts: 301
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
Quote:
Originally Posted by dhanna6powerstroke View Post
Shoud be under warranty.



I was hoping so, I'm going to try to get a hold of someone at edge tomorrow. You dont realize how much you look at your monitor untill it goes dark.
Reply With Quote Quick reply to this message
  #5  
Old 05-25-2011, 09:04 PM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Marysville, WA
Posts: 291
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I had one of the early ones and had a similar issue. There was apparently a heat related issue with a few that shipped out. Edge took care of me very quickly-- no complaints. Give them a call.

Adam
Reply With Quote Quick reply to this message
  #6  
Old 05-27-2011, 09:18 AM
Compression Ignition Addict
 

Join Date: Jun 2009
Posts: 646
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
mine shut off earlier this week and didn't come on till I cycled the key again. I check all connections and hasn't happened again but if it does I will be calling Edge about it.

I hear ya, when that thing went dark it was like losing the steering wheel, I had no idea what the heck to do, lol!
Reply With Quote Quick reply to this message
  #7  
Old 05-27-2011, 11:17 AM
Compression Ignition Addict
 

Join Date: May 2011
Location: DFW, Texas
Posts: 495
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Give Edge a call, it'll either be a quick fix or they'll get it right for you. In my experience they've stood behind their products very well.

I agree with the above tho, sounds like the backlight for the LCD screen just went out.
Reply With Quote Quick reply to this message
  #8  
Old 05-27-2011, 03:36 PM
Compression Ignition Addict
 

Join Date: Oct 2010
Location: Chestertown Md
Posts: 301
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 1 reviews
You guys were right on. One call to Edge and they simply said put in the mail and if they could not fix it they would send a new one. Great customer service
Reply With Quote Quick reply to this message
  #9  
Old 05-27-2011, 03:47 PM
Compression Ignition Addict
 

Join Date: May 2011
Location: DFW, Texas
Posts: 495
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Fox'sFord View Post
You guys were right on. One call to Edge and they simply said put in the mail and if they could not fix it they would send a new one. Great customer service
Awesome! It's customer service like that that not only keeps me coming back but gives me the confidence of recommending Edge products to anyone I can.
Reply With Quote Quick reply to this message
  #10  
Old 06-01-2011, 04:42 AM
Compression Ignition Addict
 

Join Date: Jun 2009
Posts: 646
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
update,

ran the truck for like 14 hours straight and no gliches, must have been a bad connection.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:51 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors