Blower Motor Controller gone bad? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 05-24-2011, 06:32 AM Thread Starter Fanatic
Shane3507's Avatar
Join Date: Jun 2010
Location: San Angelo, TX
Posts: 124
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Blower Motor Controller gone bad?

I have an 06 with the auto climate system. The other day I noticed the fan speed was acting up by jumping all over the place. I had the A/C and fan on at its lowest speed but it kept jumping up to HIGH SPEED and back down. I took it off auto and it did the same thing.

I've read on here that it could be the blower motor controller/relay/switch.

The only thing is that mine is not stuck on high like everyone else seems to say. Mine just varies between high and low constantly.

Any help would be appreciated.

2006 F-250 Crew Cab Lariat FX4

Mods: Line-X, UWS Low-profile toolbox, B&W Turnover Gooseneck Hitch, Edge Insight CS, Dieselsite Coolant Filtration System, CAT ELC Coolant, 4" MBRP Turbo-back, Ranch Hand Front End

Shane3507 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome