Injectors or ? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-14-2011, 05:14 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2011
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Injectors or ?

I cant recall if this issue was there before i bought it, but when the truck is in gear with my foot on the brake its a little rough(shakes a bit/rough idle) and when the tq converter locks up in high gear it will buck/chug/sounds like a miss if you try to accelerate. Oh, and it feels a little sluggish when taking off from a dead stop

Ive recently done the bullet proof egr cooler, oil cooler, t-stat, blue fuel spring, oil, every filter change, trans fluid, belt, coolant and hoses. No check engine light and i threw my sct from my other truck on there and it had no soft codes either

From what ive read it appears to be some bad injectors but my im thinking it would have these symptoms in every gear through the rpm's

so anywhere else i should be looking before i take it to the stealership
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-14-2011, 05:16 PM
Serving Our Country!
 

Join Date: Oct 2009
Location: goldsboro, north carolina
Posts: 3,830
Thanks: 1
Thanked 4 Times in 3 Posts
Feedback Score: 0 reviews
have you checked ficm voltage yet?
Reply With Quote Quick reply to this message
  #3  
Old 05-14-2011, 05:39 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2011
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have not. After all my reading i kinda skipped the ficm because everyone said they had starting problems and smoke. Mine starts right up and i just had a smog test and my particulate/smoke reading was zero. Not that it means its not bad but the ficm has been replaced once before.

I need 48 volts with the key on and 45 or more when its running?

Another thing i noticed was when i pulled the batteries out they were from 07. I know from experience that my 03 f150 will do some weird things when the battery get weak, do the super-dutys have similar problems?
Reply With Quote Quick reply to this message
  #4  
Old 05-14-2011, 06:07 PM
Compression Ignition Addict
 

Join Date: Apr 2007
Posts: 2,545
Thanks: 8
Thanked 11 Times in 8 Posts
Feedback Score: 0 reviews
yes .
Reply With Quote Quick reply to this message
  #5  
Old 05-31-2011, 07:19 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2011
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Update

Ordered a swamps 58v ficm since the previous owner was wrong about the ficm being replaced, it was the ficm wiring that got fixed on a tsb. Anyway the swamps ficm arrived this morning so i got right to it.

Once I had removed the old one I was checking things and pulled on the injector plugs to make sure they were all locked in, found one that was loose. So im fairly sure that was my problem the whole time but im glad i went with the swamps unit anyway. As soon as you turn the key the glow plug light goes out and she starts right up and purrs, and the extra power is nice too

Last edited by LvGolfer962; 05-31-2011 at 08:01 PM.
Reply With Quote Quick reply to this message
  #6  
Old 06-01-2011, 05:32 AM
Super Moderator


 

Join Date: Mar 2008
Location: Abingdon, Md.
Posts: 11,971
Thanks: 3
Thanked 29 Times in 15 Posts
Feedback Score: 3 reviews
The injector plugs should be locked in with a clip. Was that missing?
Reply With Quote Quick reply to this message
  #7  
Old 06-01-2011, 04:55 PM
Powerstroke.org Fanatic
 

Join Date: Apr 2011
Posts: 99
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by PGreenSVT View Post
The injector plugs should be locked in with a clip. Was that missing?
The clip was on but the plug wasn't seated, so it didn't get locked down.

Im just glad its back up and running right again
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:03 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors