ok need help? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-25-2011, 11:54 AM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok need help?

i just finished with putting a new oil cooler in and a egr delete. started it up last night and the y pipe going to the turbo wasnt connected right so this morning i started the truck and put it back in the garage to fix the connection. i got it fix and now the truck wont star? the only thing t touched on it today was the turbo. the truck will turn over but wont start i tried cycling the key to get any air out but the fuel system still wont pressurize. need help
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-25-2011, 12:07 PM
Let's Run'em


 
Join Date: May 2007
Location: El Paso, TX
Posts: 17,677
Thanks: 4
Thanked 13 Times in 12 Posts
Feedback Score: 2 reviews
Send a message via AIM to TwinTurboStroker
Trying cracking open the top fuel filter and then cycle the key again at least 6 times.......strange though, you didn't mess with the connections on the FICM did you?
Reply With Quote Quick reply to this message
  #3  
Old 04-25-2011, 12:12 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
no didnt mess with anything but he y pipe connection to the turbo i will try cracking open the cap
Reply With Quote Quick reply to this message
  #4  
Old 04-25-2011, 01:42 PM
Powerstroke.org Fanatic
 

Join Date: Aug 2010
Posts: 105
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
anything? i need to get this thing running i use it for work
Reply With Quote Quick reply to this message
  #5  
Old 04-25-2011, 02:06 PM
Powerstroke Techie

 

Join Date: Aug 2010
Location: Sassamansville, Pa
Posts: 9,667
Thanks: 85
Thanked 183 Times in 147 Posts
Feedback Score: 3 reviews
If you have an early '04 with the ICP behind turbo, check the ICP and IPR connection and wires. This is what my IPR wires looked liked under the heat wrap.
Reply With Quote Quick reply to this message
  #6  
Old 04-25-2011, 02:08 PM
Let's Run'em


 
Join Date: May 2007
Location: El Paso, TX
Posts: 17,677
Thanks: 4
Thanked 13 Times in 12 Posts
Feedback Score: 2 reviews
Send a message via AIM to TwinTurboStroker
Quote:
Originally Posted by Lilpooh View Post
If you have an early '04 with the ICP behind turbo, check the ICP and IPR connection and wires. This is what my IPR wires looked liked under the heat wrap.
That'll buff out........
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 06:08 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors