Airbag light flashing 32 then solid - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-16-2011, 06:33 AM
Premium Member
 

Join Date: Apr 2008
Location: Moyock, NC
Posts: 1,263
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Airbag light flashing 32 then solid

Truck started going crazy on me yesterday. Driving down the road and for the first time ever the "Water in Fuel" displayed on the dash. Then out of the blue I noticed the airbag light was lit on the dash. So, I get home and park it. This morning, I drained the water off at the fuel filter in the rail. Started it up and saw the airbag light blinking 3 then 2 a few times then it went steady lit.
Anyone ever run into this situation? I am about to run the AE to see what I get.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 02-19-2011, 06:42 PM
Premium Member
 

Join Date: Apr 2008
Location: Moyock, NC
Posts: 1,263
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Alright, since nobody has run into this. Here is what I have narrowed it down to. I believe it is the clockspring because it is intermittent. I drove it all day today and it never came back on. I haven't changed the clockspring yet, but when I do, I will post the results as well.. If it comes back again before I order the clockspring, i will post it..
Reply With Quote Quick reply to this message
  #3  
Old 02-23-2011, 06:06 PM
Premium Member
 

Join Date: Apr 2008
Location: Moyock, NC
Posts: 1,263
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Well, that damn light came back on. Was fine for a couple of days. Tonight when it started the flashing sequence, I immediately starting messing with the steering wheel controls. Everything still worked. I still think it is the clock spring because it is so irregular as to when it appears. Guess i need to go ahead and get one and swap them out.
Reply With Quote Quick reply to this message
  #4  
Old 02-23-2011, 09:21 PM
Compression Ignition Addict
 

Join Date: Oct 2007
Location: Gardner Ks
Posts: 751
Thanks: 2
Thanked 2 Times in 1 Post
Feedback Score: 0 reviews
my 04 did that and now my light is still on. what is the clock spring. i want that light off.
Reply With Quote Quick reply to this message
  #5  
Old 02-24-2011, 06:21 AM
Premium Member
 

Join Date: Dec 2009
Location: Vancouver
Posts: 3,196
Thanks: 1
Thanked 24 Times in 23 Posts
Feedback Score: 0 reviews
If you can understand this, thought I'd just do a search on code 32. Here is what I found on it.

airbag indicator [Archive] - Ford Truck Fanatics
Reply With Quote Quick reply to this message
  #6  
Old 02-24-2011, 09:26 PM
Premium Member
 

Join Date: Apr 2008
Location: Moyock, NC
Posts: 1,263
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
The clockspring is under the steering wheel. It is the electrical connection between the steering column and the wheel. It cant be a wire because the constant turning of the wheel would break it pretty quick. Don't really know what it looks like exactly, other than pics on ebay.
My situation is that it is intermittent so it has to be a connector or the clockspring.

Thanks for taking the time to search and post. I read that same thing, along with alldata. since I dont have any of those ford test thingies, I going to go about it the hard way and throw parts at it.
Reply With Quote Quick reply to this message
  #7  
Old 02-25-2011, 05:56 AM
Premium Member
 

Join Date: Dec 2009
Location: Vancouver
Posts: 3,196
Thanks: 1
Thanked 24 Times in 23 Posts
Feedback Score: 0 reviews
Let's hope you hit the target on the first throw!

Good luck!
Reply With Quote Quick reply to this message
  #8  
Old 02-25-2011, 06:02 AM
Premium Member
 

Join Date: Apr 2008
Location: Moyock, NC
Posts: 1,263
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Meeeee Toooooo...... It doesn't really bother me other than the fact that it is so random. If it was a constant issue, I would guess some of the hard parts (airbag, module, etc..) but I can go days without that light coming on. Has to be some sort of electrical gremlin... Off to order the clock spring...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:17 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors