How do i get out this damn glow plug? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-16-2011, 01:16 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2010
Location: San Antonio
Posts: 119
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How do i get out this damn glow plug?

Does anybody have a writeup or something on how to get the glowplugs out?
I've got a CEL saying that my glow plug circuit on cylinder 8 is open. When i look down in there I can see that the wire to the glow plug is crooked compared to the others. I reach down there and it is very loose almost as if piece of the top of the glow plug broke off even though the wires are still connected. How do i get the glow plug out?

I searched a bit and didn't find any detailed information, has anyone done this before?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-16-2011, 01:41 PM
Premium Member
 

Join Date: Dec 2009
Location: Vancouver
Posts: 3,111
Thanks: 1
Thanked 9 Times in 8 Posts
Feedback Score: 0 reviews
I did a search and came up with these threads, might find something in there.

This is a high powered website created just for Ford Diesel and Powerstroke enthusiasts. Older Ford 6.9L and 7.3L International or IDI owners are also welcome - Search Results for 6.0L Glow plug removal
Reply With Quote Quick reply to this message
  #3  
Old 01-16-2011, 01:48 PM
Compression Ignition Addict
 

Join Date: Aug 2007
Posts: 467
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
10mm deep socket and magnet
Reply With Quote Quick reply to this message
  #4  
Old 01-16-2011, 01:52 PM
Premium Member
 

Join Date: Dec 2009
Location: Vancouver
Posts: 3,111
Thanks: 1
Thanked 9 Times in 8 Posts
Feedback Score: 0 reviews
If that link doesn't work:

Injector and Glowplug removal - help needed

glowplug removal

why do glow plugs leak oil?
Reply With Quote Quick reply to this message
  #5  
Old 01-16-2011, 02:58 PM
Powerstroke Techie

 

Join Date: Oct 2007
Location: Saint Cloud, WI
Posts: 4,455
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Did you do any diagnostics on this? Most of the time I get this code it ends up being the control module.
Reply With Quote Quick reply to this message
  #6  
Old 01-16-2011, 03:02 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2010
Location: San Antonio
Posts: 119
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
alright i followed the instructions and pulled out the number 8 glow plug, actually had no trouble gettin the wiring harness off of it anyway i measured the resistance of the glow plug and it seemed right so then i measured to see if there was power going to the plug and there is none!. So i pulled off i guess it would be number 7 or maybe 6 i dunno how they are numbered and measured there and sure enough 12 V...Plugged my glow plug into that and grounded it and it got hot really fast, so i put the glow plug back where it goes. My question is whats the next step. I heard that the Glow plug control module can go out. Is the glow plug module the one on the passenger side valve cover right under the intercooler pipe?
Thanks
Reply With Quote Quick reply to this message
  #7  
Old 01-16-2011, 03:32 PM
Premium Member
 

Join Date: Dec 2009
Location: Vancouver
Posts: 3,111
Thanks: 1
Thanked 9 Times in 8 Posts
Feedback Score: 0 reviews
Is this what you are seeing?

Reply With Quote Quick reply to this message
  #8  
Old 01-16-2011, 03:57 PM
Powerstroke Techie

 

Join Date: Oct 2007
Location: Saint Cloud, WI
Posts: 4,455
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Check your resistance at the red wire on the black connector. That is the ckt for the #8 glow plug. If that is ok then you need a module. If you have a friend with a 6.0 then you can swap the module with theirs and see if the code goes away.
Reply With Quote Quick reply to this message
  #9  
Old 01-16-2011, 04:01 PM
Powerstroke.org Fanatic
 

Join Date: Feb 2010
Location: San Antonio
Posts: 119
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I did try that and the resistance is okay. Is it normal that only one single glow plug presents a problem? Does anyone know if the GPCM is bosch?
Thanks a bunch!!
Reply With Quote Quick reply to this message
  #10  
Old 01-16-2011, 04:06 PM
Powerstroke Techie

 

Join Date: Oct 2007
Location: Saint Cloud, WI
Posts: 4,455
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Yes it is very common. Almost all of the codes I've seen when it was a controller at fault was the #8 circuit. I've only had one that wasn't the controller.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 09:57 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors