Are my injectors missing? - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-21-2010, 03:57 PM
Premium Member
 

Join Date: Jun 2009
Location: Alabama
Posts: 5,639
Thanks: 1
Thanked 11 Times in 11 Posts
Feedback Score: 9 reviews
Are my injectors missing?

Hey guys, needless to say, I've had lots of problems with my injectors. Here's a vid, and tell me what you guys think. I know it's pretty warm, so the njector problems won't show up as much, but I plan on getting another video in the morning when she's cold. And included in that video will be the elusive hard start I've yet to find a solution for.

Here ya go, tell me what you guys think.

Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-21-2010, 04:03 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Mercer County WV
Posts: 2,988
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No, it sounds like they are still there.... if they were 'missing' the motor couldn;t get fuel and would not run




















Your motor does NOT sound like it is missing. At least not in the sense mine is (complete failure) However, my truck had some hard starting issues and cold running issues. Took it into a dealer and they ran a computer test and I had a bad FICM and three injectors getting weak. They replaced that and I had no more issues until this last weekend happened.

FWIW, you can go to a dealer and pay about $100 for a scan or you can get AE for around $250 if you search... I am going the AE route sooner or later but for now I am going to the dealer in the am....
Reply With Quote Quick reply to this message
  #3  
Old 09-21-2010, 04:05 PM
If it aint a CAT itsa DOG

 

Join Date: Apr 2007
Location: North Branch, MN
Posts: 4,553
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Just a note on the AE. If you do buy one make sure you get the pro line connector. Otherwise it won't work on the 6.0.

Last edited by dieseldan2005; 09-21-2010 at 04:17 PM.
Reply With Quote Quick reply to this message
  #4  
Old 09-21-2010, 04:07 PM
Premium Member
 

Join Date: Jun 2009
Location: Alabama
Posts: 5,639
Thanks: 1
Thanked 11 Times in 11 Posts
Feedback Score: 9 reviews
Quote:
Originally Posted by 05_PSD_Erik View Post
No, it sounds like they are still there.... if they were 'missing' the motor couldn;t get fuel and would not run




















Your motor does NOT sound like it is missing. At least not in the sense mine is (complete failure) However, my truck had some hard starting issues and cold running issues. Took it into a dealer and they ran a computer test and I had a bad FICM and three injectors getting weak. They replaced that and I had no more issues until this last weekend happened.

FWIW, you can go to a dealer and pay about $100 for a scan or you can get AE for around $250 if you search... I am going the AE route sooner or later but for now I am going to the dealer in the am....
Haha I know I noticed the title right after I posted it.

FICM was replaced a week ago, long with another injector.

And BTW, the truck is still under warranty.
Reply With Quote Quick reply to this message
  #5  
Old 09-21-2010, 04:07 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Mercer County WV
Posts: 2,988
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by dieseldan2005 View Post
Just a note on the AE. If you do buy one make sure you get the pro link connector. Otherwise it won't work on the 6.0.
Thanks DD!
(and Sick, sorry for the hijack I'm learning...) Lol

How in the h3ll do you have warranty on your truck????
Reply With Quote Quick reply to this message
  #6  
Old 09-21-2010, 04:12 PM
Premium Member
 

Join Date: Jun 2009
Location: Alabama
Posts: 5,639
Thanks: 1
Thanked 11 Times in 11 Posts
Feedback Score: 9 reviews
Quote:
Originally Posted by 05_PSD_Erik View Post
Thanks DD!
(and Sick, sorry for the hijack I'm learning...) Lol

How in the h3ll do you have warranty on your truck????
No problem, thats what we're here for, to teach and learn.



And I have Ford ESP until November, so I wanna get all problems resolved before then.
Reply With Quote Quick reply to this message
  #7  
Old 09-21-2010, 05:24 PM
Compression Ignition Addict
 

Join Date: Feb 2009
Location: Mercer County WV
Posts: 2,988
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sweetness on the ESP, and you dont have problems with being studded and tuned... awesome


lol to the role reversal on the hijacking...
Reply With Quote Quick reply to this message
  #8  
Old 09-21-2010, 05:29 PM
I wanna go fast!!!
 

Join Date: Sep 2007
Location: Rio Hondo, Texas
Posts: 2,388
Thanks: 1
Thanked 7 Times in 6 Posts
Feedback Score: 2 reviews
That doesn't sound like its missing to me?
Reply With Quote Quick reply to this message
  #9  
Old 09-21-2010, 05:29 PM
NOT a Democrat
 

Join Date: Oct 2009
Location: Robinson Twp PA (Pittsburgh)
Posts: 4,511
Thanks: 2
Thanked 3 Times in 3 Posts
Feedback Score: 0 reviews
Send a message via AIM to Galaxie
Sounds good to me.
Reply With Quote Quick reply to this message
  #10  
Old 09-21-2010, 05:46 PM
Premium Member
 

Join Date: Jun 2009
Location: Alabama
Posts: 5,639
Thanks: 1
Thanked 11 Times in 11 Posts
Feedback Score: 9 reviews
Quote:
Originally Posted by 05_PSD_Erik View Post
Sweetness on the ESP, and you dont have problems with being studded and tuned... awesome


lol to the role reversal on the hijacking...
Haha no joke, I have the greatest dealer on the face of the planet. They've helped me out a lot. LOL they actually tried to sell me a programmer!!

Quote:
Originally Posted by 07stroker View Post
That doesn't sound like its missing to me?
Quote:
Originally Posted by Galaxie View Post
Sounds good to me.
Thanks for the comments guys, I'm having trouble learning what a miss is, so I just wanted to make sure mine wasn't. I'm gonna post up a video tomorrow of a cold start, as that seems to be when most injector problems are evident.

And maybe you guys can help me resolve this hard start/long crank issue as well.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 07:36 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors